Maxim Flat Processing

Discussion in 'Image Processing' started by Kent DeGroff, Sep 5, 2016.

  1. Kent DeGroff

    Kent DeGroff Standard User

    Joined:
    Nov 24, 2014
    Messages:
    7
    Maxim seems to use the last flat in the calibration list that matches the size of the light frame regardless if filter color. These snippets from the fits header for a combined green image apparently show the red flat being used (blue also uses the Red flat):
    ------------------------------------------------------
    READOUTM = 'Raw ' / Readout mode of image
    FILTER = 'Green ' / Filter used when taking image
    IMAGETYP = 'Light Frame' / Type of image
    ------------------------------------------------------
    INPUTFMT = 'FITS ' / Format of file from which image was read
    SWMODIFY = 'MaxIm DL Version 6.06 141003 0S085' /Name of software
    HISTORY Bias Subtraction (Bias 2, 1676 x 1266, Bin2 x 2, Temp -25C,
    HISTORY Exp Time 0ms)
    CALSTAT = 'BDF '
    HISTORY Dark Subtraction (Dark 26, 1676 x 1266, Bin2 x 2, Temp -30C,
    HISTORY Exp Time 150s)
    HISTORY Dark-Bias(Bias 2,1676 x 1266,Bin2 x 2,Temp -25C,Exp Time 0ms)
    HISTORY Flat Field (Flat Red 3, Red, 1676 x 1266, Bin2 x 2, Temp -25C,
    HISTORY Exp Time 3s)
    HISTORY Flat-Bias(Bias 2,1676 x 1266,Bin2 x 2,Temp -25C,Exp Time 0ms)
    PEDESTAL = -100 /Correction to add for zero-based ADU
    SNAPSHOT = 8 /Number of images combined
    -----------------------------------------------------------------------------------------

    Why is this happening?

    Thanks for any help/explanation you can offer,
    Kent
     
  2. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    2,757
    Your Filter name is 'Green ', not 'Green'. There's an extra space at the end. So MaxIm DL can't find a match for the flat field, and picks something "close", which happens to be the wrong one.
     
  3. Kent DeGroff

    Kent DeGroff Standard User

    Joined:
    Nov 24, 2014
    Messages:
    7
    Hi Doug,

    Thanks for the quick response. I have put a screen dump showing a snippet of the Maxim log with the flats loaded, the master flat header used, and a green image used in the combine here:

    https://www.dropbox.com/s/dcoagm5gucl0d98/MaximFlat.jpg?dl=0

    The names in the headers appear to be the same with 3 extra spaces each for a total of 8 characters. The single space seen in my original post (6 characters for the name) comes from the Maxim combine header for green. I don't understand how it happens that the input names, which agree, produce an output name that is different.

    Regards,
    Kent
     
  4. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    2,757
    Best thing to do would be to upload your FITS frames so we can have a look. Send to ftp.cyanogen.com, anonymous login, you can use the free utility Filezilla.
     
  5. Kent DeGroff

    Kent DeGroff Standard User

    Joined:
    Nov 24, 2014
    Messages:
    7
    Hi Doug,

    I uploaded a set of files via ftp to the incoming directory (I think). I couldn't see any files in that directory for some reason but when I tried to do it again got an existing file error so I assume it made it. I could see the files in Pub.

    I distilled the files to the minimum required to illustrate the problem. I'm sure it's something stupid on my part but I ran Maxim on that set and got the same problem. It'll be interesting to see what you find.

    Regards (and I appreciate the help),
    Kent
     
  6. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    2,757
    Your Green master flat is binned 1x1, all other files are binned 2x2. It's not picking it up because it doesn't match.
     
  7. Kent DeGroff

    Kent DeGroff Standard User

    Joined:
    Nov 24, 2014
    Messages:
    7
    Hi again Doug,

    Well, I messed up when I built the zip file. I corrected it with the file shown in the screen dump sent earlier. It still has the problem, at least for me. I sent a new file. Can you check it out?

    Thanks,
    Kent
     
  8. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    2,757
    All the calibrations worked correctly - flat blue on blue image, flat green on green image, flat red on red image.
     
  9. Kent DeGroff

    Kent DeGroff Standard User

    Joined:
    Nov 24, 2014
    Messages:
    7
    Hello again Doug,

    I'm glad the processing worked correctly for you, but it doesn't for me. I have uploaded a new zip with the log from Maxim as processed on that same set of files and the actual combined images R,G,B. They each have this line in the FITS header:

    HISTORY Flat Field (Flat Red 1, Red, 1676 x 1266, Bin2 x 2, Temp -25C,

    I am really puzzled. Can you take another look and see what might be wrong?

    Thanks,
    Kent
     
  10. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    2,757
    ZIP your settings and post those, please. (It's under My Documents)
     
  11. Kent DeGroff

    Kent DeGroff Standard User

    Joined:
    Nov 24, 2014
    Messages:
    7
    Done.

    Kent
     
  12. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    2,757
    Still works fine with your settings.

    The FITS header says you are using an older version. Please use Help menu Check For Updates.

    This is my result for NGC69790002G.fit:

    SIMPLE = T
    BITPIX = 16 /8 unsigned int, 16 & 32 int, -32 & -64 real
    NAXIS = 2 /number of axes
    NAXIS1 = 1676 /fastest changing axis
    NAXIS2 = 1266 /next to fastest changing axis
    BSCALE = 1.0000000000000000 /physical = BZERO + BSCALE*array_value
    BZERO = 32768.000000000000 /physical = BZERO + BSCALE*array_value
    DATE-OBS = '2014-11-19T02:46:09' /YYYY-MM-DDThh:mm:ss observation start, UT
    EXPTIME = 150.00000000000000 /Exposure time in seconds
    EXPOSURE = 150.00000000000000 /Exposure time in seconds
    SET-TEMP = -30.000000000000000 /CCD temperature setpoint in C
    CCD-TEMP = -29.724637204887038 /CCD temperature at start of exposure in C
    XPIXSZ = 10.800000000000001 /Pixel Width in microns (after binning)
    YPIXSZ = 10.800000000000001 /Pixel Height in microns (after binning)
    XBINNING = 2 /Binning factor in width
    YBINNING = 2 /Binning factor in height
    XORGSUBF = 0 /Subframe X position in binned pixels
    YORGSUBF = 0 /Subframe Y position in binned pixels
    READOUTM = 'Raw ' / Readout mode of image
    FILTER = 'Green ' / Filter used when taking image
    IMAGETYP = 'Light Frame' / Type of image
    FOCALLEN = 1918.0000000000000 /Focal length of telescope in mm
    APTDIA = 457.00000000000000 /Aperture diameter of telescope in mm
    APTAREA = 153777.77399243787 /Aperture area of telescope in mm^2
    EGAIN = 0.37000000476837158 /Electronic gain in e-/ADU
    SBSTDVER = 'SBFITSEXT Version 1.0' /Version of SBFITSEXT standard in effect
    SWCREATE = 'MaxIm DL Version 6.06 141003 0S085' /Name of software
    SWSERIAL = '2CKU4-XU0FM-MYY35-X7JCC-9FNT8-NE' /Software serial number
    FOCUSPOS = 914 /Focuser position in steps
    OBJECT = 'NGC 6979'
    OBJCTRA = '20 50 35' / Nominal Right Ascension of center of image
    OBJCTDEC = '+32 00 39' / Nominal Declination of center of image
    OBJCTALT = ' 57.0813' / Nominal altitude of center of image
    OBJCTAZ = '279.5558' / Nominal azimuth of center of image
    OBJCTHA = ' 2.6151' / Nominal hour angle of center of image
    PIERSIDE = 'EAST ' / Side of pier telescope is on
    SITELAT = '32 49 48' / Latitude of the imaging location
    SITELONG = '-108 12 32' / Longitude of the imaging location
    JD = 2456980.6153819445 /Julian Date at start of exposure
    JD-HELIO = 2456980.6163407983 /Heliocentric Julian Date at exposure midpoint
    AIRMASS = 1.1835324391293005 /Relative optical path length through atmosphere
    TELESCOP = 'WCO Main' / telescope used to acquire this image
    INSTRUME = 'SBIG ST-8300 CCD Camera'
    OBSERVER = 'Kent DeGroff'
    NOTES = ' '
    FLIPSTAT = ' '
    SWOWNER = 'Kent G DeGroff' / Licensed owner of software
    INPUTFMT = 'FITS ' / Format of file from which image was read
    SWMODIFY = 'MaxIm DL Version 6.13 160526 2CKU4' /Name of software
    HISTORY Bias Subtraction (Bias 1, 1676 x 1266, Bin2 x 2, Temp -25C,
    HISTORY Exp Time 0ms)
    CALSTAT = 'BDF '
    HISTORY Dark Subtraction (Dark 1, 1676 x 1266, Bin2 x 2, Temp -30C,
    HISTORY Exp Time 150s)
    HISTORY Dark-Bias(Bias 1,1676 x 1266,Bin2 x 2,Temp -25C,Exp Time 0ms)
    HISTORY Flat Field (Flat Green 1, Green, 1676 x 1266, Bin2 x 2, Temp -25C,
    HISTORY Exp Time 2s)
    HISTORY Flat-Bias(Bias 1,1676 x 1266,Bin2 x 2,Temp -25C,Exp Time 0ms)
    HISTORY Flat-Dark (Dark 1,1676 x 1266,Bin2 x 2,Temp -30C,Exp Time 150s)
    PEDESTAL = -100 /Correction to add for zero-based ADU
     
  13. Kent DeGroff

    Kent DeGroff Standard User

    Joined:
    Nov 24, 2014
    Messages:
    7
    Thanks for checking that out. So I guess none of my images where I used flats have been processed correctly. I'm kinda bummed, but bad on me for not tumbling to it sooner - at least before my warranty ran out.

    See ya'
    Kent
     

Share This Page