[RESOLVED]Readout mode greyed out (Disabled) in Maxim DL when ising with Andor CCD

Discussion in 'Demo User Tech Support' started by Aum Shethia, Aug 18, 2016.

  1. Aum Shethia

    Aum Shethia Standard User

    Joined:
    Aug 18, 2016
    Messages:
    6
    I have connected Andor iXon EMCCD 888 with Maxim dl, i have installed drivers in the Maxim dl software directory and Maxim dl can detect the ccd fine. When i click on discover, i see my ccd model number but when i go to "expose" tab, the "readout" is grayed out (Disabled). Please help me how to enable the readout speeds since this ccd has multiple readout rates.
    Also help me from where can i change the EMCCD's gain values?

    Thank you.
     
  2. Tim

    Tim Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    1,611
    If you hover your mouse over the Readout Mode box, it should tell you why it is grayed out, and how to enable it. The most common reason is that you have "Autosave" set on the Expose tab. You can only set readout mode for Single or Continuous exposures.

    All camera specific settings are on the "Camera Control" window, "Setup" tab. Click the "Setup Camera" button and select the "Advanced" button. There are further details in the users manual here:

    http://www.cyanogen.com/help/maximdl/Andor.htm
     
  3. Aum Shethia

    Aum Shethia Standard User

    Joined:
    Aug 18, 2016
    Messages:
    6
    Dear Sir, everything else works very well since i followed the same procedure as mentioned in user manual. in advance tab i can see the read rates (read speed frequencies), vertical shift rates etc, the camera is getting detected and cools down normal. however the read rates visible are for EM mode only and not for conventional ccd mode. secondly i could not find the gain settings (to apply gain values like x 100 times or x 800 times etc).
    Thank you very much for your prompt reply, i shall look into "auto save" settings tomorrow since my lab is closed for the day.
    Just to double check with you, can i rule out mismatch of any drivers of Andor required to run this iXon ULTRA 888 ccd ? Hope this ccd is fully supported by maxim dl, please confirm this to me.

    Thank you once again, have a great day!

    Aum Shethia
    India.
     
  4. Aum Shethia

    Aum Shethia Standard User

    Joined:
    Aug 18, 2016
    Messages:
    6
    Dear Sir,
    I just checked my settings for Auto save, its not set by me. I am operating it on single exposure setting only, still the readout mode tab is disabled. My primary purpose is to find the option from where i can apply gain settings and make the EMCCD camera run on EM mode or Conventional CCD mode. I would be really very grateful if you could help me were can i apply these settings.

    Attached is the datasheet of the EMCCD i am using and plan to purchase the latest version of Maxim dl if it serves my purpose.
     

    Attached Files:

  5. Adam Robichaud

    Adam Robichaud Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    698
    Location:
    Ottawa
    I've sent you a private message with a beta-version of our Andor Tech plugin that should give you control over the EMCCD features of your camera. Don't hesitate to contact us if you encounter any issues.
     
  6. Aum Shethia

    Aum Shethia Standard User

    Joined:
    Aug 18, 2016
    Messages:
    6
    Hello Sir,
    Thanks a ton for your help!
    The plugin worked well and EM settings were visible. Cheers to Diffraction LTD team!
     
    Adam Robichaud likes this.
  7. Lauchie Scott

    Lauchie Scott Cyanogen Customer

    Joined:
    Apr 21, 2018
    Messages:
    1
    I think there's been an update on the EMCCD driver. Would it be possible to get a copy? I believe that shutter control should be enabled on the Andor iXon 888 now.
     
  8. Adam Robichaud

    Adam Robichaud Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    698
    Location:
    Ottawa
    Hi Lauchie, please check your private messages.

    Cheers,
    -A
     
  9. Tolga

    Tolga Standard User

    Joined:
    Nov 19, 2016
    Messages:
    3
    Hi there I also have an Andor iXon 888 and trying use within MaximDL 5. Would it be possible for you to send me the latest driver that you mention in this post.

    regards
    tolga
     
  10. Tim

    Tim Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    1,611
    Beta versions, and updated camera support is only available with a current MaxIm DL Pro subscription. You will need to update to version 6 to receive the latest AndOr plugin.
     
  11. Emilio

    Emilio Standard User

    Joined:
    Apr 23, 2019
    Messages:
    1
    Location:
    Granada
    Hello,
    I'm using MaxIm DL pro 6, I have the same problem.
    We have an Andor iXon EMCCD 888 camera and other iXon EMCCD 897, we'd like to change EM gain and to switch between EMCCD and CCD mode too.
    Thank you.
    Regards,
    Emilio.
     
  12. Karsten Schindler

    Karsten Schindler Cyanogen Customer

    Joined:
    Jan 21, 2015
    Messages:
    36
    Location:
    Moffett Field, CA
    Hi Andor iXon 888 users - there is a long standing issue with the beta Andor camera plugin: As you would expect, the image content flips horizontally (in x-pixel direction) when you change between EM and conventional output, as the EMCCD's serial register clocks charges either to the left or to the right, depending on which amplifier you choose. However, it appears that any calls to MaximDL's API that involve the definition of a subframe exposure get flipped in x-direction as well.
    So when you are using a 3rd party program like FocusMax that commands MaximDL through its API for commanding subframe exposures - first, picking a suitable star in an image for focusing, then commanding an exposure of an area of interest around it - you will notice that this will only work when you use the camera's EM output. When using the conventional output (which has significantly less read noise), any subframe definition will will miss the respective star. After systematic testing I figured that the subframe is placed at the correct y coordinate, but ends up on the opposite side of the image in x direction. Any subframe definition only comes out right in images that passed the EM amplifier, but not in images that passed the conventional amplifier.
    It seems this is a simple sign error and it would be awesome DL would be able to fix this issue so the conventional amplifier readout can be used in observatory scripting and automation.
    Maybe other users in this forum can confirm this behavior...
     
  13. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    6,082
    Karsten - thank you for reporting that. To make sure it doesn't get lost, I'm copying your post into a separate thread in the main MaxIm DL technical support area. It really needs its own ticket, and not buried in the demo support area!
     
  14. Tolga

    Tolga Standard User

    Joined:
    Nov 19, 2016
    Messages:
    3
    Hi I have a probably simpler problem regarding the use of andor ixon 888 within maximdl. Thanks to the MAXIM DL support I also use the beta version. But here is my problem, when we setup the camera from the advanced setup menu we can set the gain values EM off conventional CCD modes etc. but then to the best of my knowledge there is no way of remembering what we initially selected since each time we get into this part we have to re-discover the CCD which sets to default values. and again as much as I know this information is not written to the header. is it in anyways possible for us to somehow save these settings in the maximdl or just make them written to the header of each file.

    thanks a lot
     
  15. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    6,082
    You can manually set keywords to be added to the header in File menu Settings.

    We have no plans at the moment to add any additional functionality the plug-in.
     

Share This Page