STT8300M - Banding Problem

Discussion in 'STT Series (obsolete)' started by D Simpson, Jan 27, 2019.

  1. D Simpson

    D Simpson Cyanogen Customer

    Joined:
    Oct 10, 2014
    Messages:
    54
    Location:
    Santa Fe, New Mexico
    The images from my STT8300M seem to have developed a distinct horizontal banding. I've attached an example.

    Any suggestions?
     

    Attached Files:

  2. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    5,299
    I don't think it can be an electrical issue. The lines are not perfectly horizontal - they wander vertically. The fast clocking is in the horizontal direction, so any baseline variation or noise should be perfectly horizontal.

    Most likely this is optical. Perhaps something is fogging up. I notice some mild diagonal streakiness inside the bright band; that certainly suggests fogging.

    I'd recommend baking the desiccant.
     
  3. D Simpson

    D Simpson Cyanogen Customer

    Joined:
    Oct 10, 2014
    Messages:
    54
    Location:
    Santa Fe, New Mexico
    Thanks Doug, I'll give that a try.
     
  4. D Simpson

    D Simpson Cyanogen Customer

    Joined:
    Oct 10, 2014
    Messages:
    54
    Location:
    Santa Fe, New Mexico
    Hi Doug,
    I baked the desiccant plug according to directions and I'm still getting the banding. In fact it seems worse. I've attached a couple of shots including a dark frame to rule out stray ambient light. It's happening with the cooler on or off.

    Let me know what you think.
    Thanks
     

    Attached Files:

  5. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    1,761
    Dan, Doug is out of the office for a day of well-deserved vacation, so I thought I'd take a look.
    I agree with Doug that it doesnt look like an electronic problem, looks more like contamination on the sensor or optical window, but then it shouldnt show in the dark frame.

    A few things that might help us diagnose:
    Can you shoot a BIAS frame and post it ?
    Did you cover the camera so no light gets in when doing the dark?
    Have you eyeballed the sensor? e.g. put the camera on the workbench, spin to a clear filter, and fired off a long exposure so that the shutter opens and you can see through the optical window to the chip?

    What happens if you turn off the RBI pre-flash ?
     
  6. D Simpson

    D Simpson Cyanogen Customer

    Joined:
    Oct 10, 2014
    Messages:
    54
    Location:
    Santa Fe, New Mexico
    Thanks Colin, for looking into this.

    I should be able to take some bias and darks tonight, no matter the weather. I will say the dark frame I sent you was taken last night under very dark skies. I'll try again with a cover.

    I'll also check my RBI settings and see if changing those makes a difference.

    Thanks for the suggestions.
    Take Care,
     
  7. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    1,761
    Also if you can eyeball the sensor when it is down to -30C, see if there is any frost on the sensor or chamber window after its cooled down for a while.
     
  8. D Simpson

    D Simpson Cyanogen Customer

    Joined:
    Oct 10, 2014
    Messages:
    54
    Location:
    Santa Fe, New Mexico
    Hi Colin, I managed to get some bias frames and darks this morning. My observatory isn't that dark during the day but covering the camera seemed to do the trick - at least for testing purposes. I've attached a zip of four dark frames which should make clear what the problem was. What I found was the Readout Mode was set to Fast w/RBI pre-flash. That dark frame had some very obvious banding. Setting the Readout Mode to Normal w/RBI pre-flash also showed the banding. When I set the Readout Mode to just Normal or Fast the banding went away. Problem solved but I do have a couple of questions related to this.

    Some time ago Tim Puckett helped me set the RBI exposure time to zero. At the time I didn't need the RBI. I've looked in Help but I can't seem to find where that setting is located. Could you point me to a discussion on using RBI?

    Is there any other reason why the Readout Mode would mysteriously change to the Fast w/RBI pre-flash setting - other than I mistakenly changed it myself? Would ACP do this?
    Thanks again for taking a look at this,
     

    Attached Files:

  9. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    1,761
    See attached image - will show you how to set on the Advanced tab.
    If RBI is on incorrectly/too long, and the camera is in the readout mode, you may get reflections from the light source that does the RBI- and this might account for the weird effects.

    ACP has a file for setting the readout modes, am pretty sure it is called RoModeInfo.txt with the readout modes.
    I believe the is also a #romode or similar directive you can put in ACP Scheduler plans to change the mode.

    Doug will likely chime in when he gets back.
     

    Attached Files:

  10. D Simpson

    D Simpson Cyanogen Customer

    Joined:
    Oct 10, 2014
    Messages:
    54
    Location:
    Santa Fe, New Mexico
    Hi Colin,
    Didn't have much luck last night the wind really picked up. Forecast to stay windy for the next few days. I did end up with a couple of questions.

    When I looked at the RBI Pre-Flash settings those settings are grayed out so I can't change them. The Flash Length and Flush Count both show a grayed out zero. Just as an FYI, I had to change the Camera Model to "SBIG Universal" to get the Advanced button to show itself.

    Also, while I've got you, where does the ACP RoModeInfo.txt file reside? I can't seem to locate it.
    Thanks,
    Dan
     
  11. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    1,761
    Check what the FITS header says for your darks/bias images, if there is a line about the readout mode.

    RoModeInfo.txt usually lives here:
    C:\Users\Public\Documents\ACP Config
     
  12. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    5,299
    I'll chime in on this one. If it was long ago enough, it may have been before we made major changes to the RBI support. We didn't like how it was implemented by the old company, and made significant improvements. Setting it to zero is no longer the recommended way to disable it. You need to set the Readout Mode. Also we recommend using the latest drivers, firmware, and MaxIm DL 6.13 or higher.
     
  13. D Simpson

    D Simpson Cyanogen Customer

    Joined:
    Oct 10, 2014
    Messages:
    54
    Location:
    Santa Fe, New Mexico
    Thanks Doug,
    Okay, I just last week updated drivers and firmware and am running MaxIm DL 6.2. I did figure out how to get ACP to select the readout modes I wanted.

    I'm not at the observatory computer but I would guess that I have to set the readout mode on the expose tab to one of the w/pre-flash modes to activate the Readout setting on the options window. I've been working on other issues these past couple of months - guiding, AO guiding, rotators... - so I haven't felt the need to revisit until I found ACP was resetting the Readout Mode.

    So, a couple more questions: Do you recommend using the RBI Pre-flash? What would you recommend setting the Readout Mode options numbers to?
    Thanks,
    Dan
     
  14. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    5,299
    I would use Normal almost all the time.

    The only situation where RBI mitigation is useful is when you have an extremely bright star in the field. That causes the residual bulk image problem.

    The RBI mitigation works by flooding the sensor with IR, which basically makes RBI happen to the maximum degree everywhere on the chip. Then you do your dark frames with RBI preflash running also, so that when you subtract the bulk image is eliminated. Unfortunately this also adds a certain amount of excess photon shot noise to the image, which degrades your SNR modestly. So we recommend you NOT use RBI unless the field your are imaging forces you to.

    While the KAF-8300 sensor can exhibit RBI behavior, it is NOT one of the worst offenders (the worst offender be the KAF-09000). Most people never need to use RBI mitigation.
     
  15. D Simpson

    D Simpson Cyanogen Customer

    Joined:
    Oct 10, 2014
    Messages:
    54
    Location:
    Santa Fe, New Mexico
    Good information. Thanks Doug.
     

Share This Page