what limits travel in autofocus

Discussion in 'Image Capture' started by Terry Standefer, Feb 9, 2016.

  1. Terry Standefer

    Terry Standefer Cyanogen Customer

    Joined:
    Oct 21, 2015
    Messages:
    31
    Spent last night trying to use the autofocus feature in MaximDL 6.0 with Robofocus. The OTA is an TAK FSQ106N, astrophysics 900 mount and the camera is an SBIG STL11000M. The robofocus calibrates just fine using the Robofocus driver by Technical Innovations. It also acts correctly by moving in and out with both the Robo driver and Maxim DL focus. When I connect the robofocus in Maxim it connects just fine and Maxim can control the focus (in and out) in the Focus tab, but when I try to the autofocus routine to fine the v curve and optimum focus point , it continues to go past the the max travel defined in robofocus and extends all the way until the star image gets so large it is not decteced (this is even after enlarging the focus box to 200x200.) I captured screen shots below showing my setting for the robofocus and for Maxim DL auto focus.

    I am currently using FocusMax with no issue, but I purchased the upgrade to Maxim DL to get the focus routine and have a one stop shopping for my image capture.

    My basic question is what sets the maximum travel in Maxim autofocus. I probabily am missing something simple. Any help would be apprecited.[​IMG]

    Here is a shot of the AutoFocus in Maxim before it crashed:
    [​IMG]

    [​IMG]

    Attached Files:
    Terry Standefer, Wednesday at 10:43 PM Edit Report
    #1 Reply
    [​IMG]
    Terry Standefer Standard User
    Send a Private Message
    Joined:
    Oct 21, 2015
    Messages:
    2
    Terry Standefer said:
    Spent last night trying to use the autofocus feature in MaximDL 6.0 with Robofocus. The OTA is an TAK FSQ106N, astrophysics 900 mount and the camera is an SBIG STL11000M. The robofocus calibrates just fine using the Robofocus driver by Technical Innovations. It also acts correctly by moving in and out with both the Robo driver and Maxim DL focus. The issue is with AutoFocus. When I run the routine, it continues to go past the focus point to where the focuser extends all the way out well beyond the maximum travel point, then the routine crashes windows and reboots. I captures screen shots below showing my setting for the robofocus and for Maxim DL auto focus. If any of you are using a similar setup I would be interested in the parameters you are using or if you can see something obvious I am not doing.

    View attachment 1380

    Here is a shot of the AutoFocus in Maxim before it crashed:
    View attachment 1379

    View attachment 1381
    Click to expand...​
    Let me ask another question regarding my issue with the auto focus function in maximdl. How does maxim know how far to move and in and out without going too far. Does it go by the maximum travel in robofocus or by the step size in maxim or by how large the star is when measuring it's diameter or all the above? I am accustomed to using focus max with my robofocus. There seems to be a lot more control with it. I purchased the upgrade for maxim, mainly for the auto focus addition.

    I did discover the reason for Windows crashing. The usb to serial needed to be replaced.

    Terry
     

Share This Page