Andor iKON-L 936 Advanced Settings in Maxim DL

Discussion in 'Off Topic' started by Jon Swift, Oct 10, 2022.

  1. Jon Swift

    Jon Swift Cyanogen Customer

    Joined:
    Apr 26, 2015
    Messages:
    20
    Location:
    Ojai, CA
    I have an Andor iKON-L 936 with the latest drivers installed. The camera has a number of configuration settings, such as readout rate, preamp gain, etc. Several of these are available in Maxim DL's Advanced settings in the camera setup. But there are a few that do not seem to be accessible.

    In particular, I am wanting to change the output amplifier from high sensitivity mode to high capacity mode. Any tips on how to do this in Maxim DL?

    Thanks!
    Jon
     
  2. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    9,315
  3. Jon Swift

    Jon Swift Cyanogen Customer

    Joined:
    Apr 26, 2015
    Messages:
    20
    Location:
    Ojai, CA
    Just did, and reposted in that forum. Thanks, Doug!
     
  4. Jon Swift

    Jon Swift Cyanogen Customer

    Joined:
    Apr 26, 2015
    Messages:
    20
    Location:
    Ojai, CA
    Update:

    I installed the latest ASCOM platform on my control computer and also installed a new driver for our camera provided by Andor—Andor CCD/EMCCD (SDK2). I was using the Andor Tech driver for my camera (which may have been written by Diffraction Limited?) Operating my camera in Maxim DL with this driver allows me to choose all of the settings I need. That is the good news.

    The bad news is that now I am getting strange problems with the coordinated control of our filter wheels (dual FLI 7 slot wheels) and camera. Sometimes (but not always), when filters are switched between exposures (either manually or through Autosave), an error message comes up that says the filter wheel is not connected (see attached screenshot).

    This is not a power supply or USB issue. It seems to have something to do with Maxim DL waiting (or not waiting) for the filter wheels to change positions before trying to expose.

    I have tried to toggle some of the options in the Advanced settings in the options button of the camera setup. In particular, I’ve tried enabling both threading for the filter wheel and camera, and not allowing threading. In both circumstances, I’ve run into the same problem.

    Any suggestions would be greatly appreciated.
     

    Attached Files:

  5. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    6,408
    Location:
    Earth
    Is the FLI Filter wheel pair being controlled by the old Andor driver or the new Andor driver?
    e.g. am trying to figure out if MaxIm is sending commands to two different drivers, or one driver.

    e.g. something like one of these combos:
    Camera 1 ---> Andor New Driver
    Filter Wheel 1&2 combined pair ---> Andor old dual wheel driver
    OR
    Camera 1 ---> Andor New Driver
    Filter Wheel 1&2 combined pair ---> Andor New Driver
    OR
    Camera 1 ---> Andor New Driver
    Filter Wheel 1&2 combined pair ---> MaxIm Dual Wheel Driver --> Andor old single wheel driver #1, and Andor old single wheel driver #2
     
  6. Jon Swift

    Jon Swift Cyanogen Customer

    Joined:
    Apr 26, 2015
    Messages:
    20
    Location:
    Ojai, CA
    Camera 1 --> Andor CCD/EMCCD (SDK2), which is what we're calling the New Andor Driver
    Filter Wheels 1&2 --> Dual Wheels Driver

    I've attached some screen shots for reference. Screen Shot 2022-10-21 at 8.27.58 AM.png Screen Shot 2022-10-21 at 8.28.32 AM.png
     
  7. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    6,408
    Location:
    Earth
    Here's a thought:
    Try skipping Dual Wheels, and just see if you can get a single wheel to connect and operate through that Andor CCD/EMCCD (SDK2) driver.
    Then change the properties to see if you can get the other wheel in the pair to go.
    Then set up Dual.
     

Share This Page