CCDOps Crashed during Setup with SBIG ST-8300M

Discussion in 'Legacy Models (ST, STL, etc.)' started by AstroPal, Jul 3, 2019.

  1. AstroPal

    AstroPal Standard User

    Joined:
    Jul 3, 2019
    Messages:
    3
    Location:
    Ottawa, ON
    Greetings Everyone,

    I have recently bought a used SBIG ST-8300M from a local astronomer that's getting out of the hobby. I've downloaded the most recent copy of SBIGUniversal Driver and CCDOPS and have installed both of them successfully in Windows 10 64-bit.

    So far, everything works according to plan. I was able to connect and shutdown the camera in CCDOPS with no problems. Displaying the camera specs in CCDOPS also works fine and the info looks correct. However, when I tried to into Setup (Control-U), CCDOPS crashed (or exit) without any warning. I've tried this numerous times with no luck. I even go as far as uninstalling both SBIGUniversal Driver and CCDOPS followed by reinstallation, same problem.

    I was able to connect the camera with APT with no issues (haven't taken any images yet though) and was able to control the sensor temperature; seems to be working so far.

    Anyone know what's going on? I've spoke with a buddy of mine that's using CCDOPS and he said it's quite stable and he is not having issues with it.
     
  2. Tim

    Tim Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    1,621
    I see you have updated your drivers with the SBIGDriverChecker64 presumably. But did you check to see if there are any firmware updates available for the camera as well? Can you tell me what firmware versions you currently have installed on the camera? You can check it on the "Firmware" tab in the same SBIGDriverChecker64 program.
     
  3. AstroPal

    AstroPal Standard User

    Joined:
    Jul 3, 2019
    Messages:
    3
    Location:
    Ottawa, ON
    Hello Tim,

    When I goto the Firmware Tab of the SBIGDriverChecker64, I get the following:

    upload_2019-7-17_21-54-51.png

    However, when I start up CCDOps and go to the Camera Info area, I get the following info:

    upload_2019-7-17_21-54-38.png

    Whenever I try to go the Setup section (Control-U), CCDOps crashed/exited.
     
  4. Tim

    Tim Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    1,621
    Have you tried the camera using a different computer?
     
  5. AstroPal

    AstroPal Standard User

    Joined:
    Jul 3, 2019
    Messages:
    3
    Location:
    Ottawa, ON
    I just installed the drivers and CCDOps on a different computer (a desktop this time), got the exact same symptoms....
     
  6. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    2,427
    Hi AstroPal,
    Make sure you aren't running both programs at the same time (am sure you aren't but sometimes people start one and leave it running, and the camera gets unhappy if it tries to be accessed by more than 1 program).

    If that's not it, then let's travel back in time to an old version of the programs.

    Can you uninstall CCDOPS, uninstall SBIGDriverCheck, and then try installing just this:
    http://diffractionlimited.com/downloads/sbig/SetupDriverChecker64_3R11B4.exe
    This is a really old version of the driver checker, and it might be able to talk to your camera.
    Give that a try, and then see if the the firmware tab will talk to the camera.
    If it works, see if it can find a firmware update and try to install it. BE VERY PATIENT as it can take many minutes on these older cameras.

    If that works, then try this version of CCDOPS:
    http://diffractionlimited.com/downloads/sbig/InstOps_5R53B28.exe

    Let us know how it goes.

    Regarding the private message you sent me about using an ST-IC and another SBIG camera simultaneously with two other programs, am not sure if that will work with the programs you mention.
    Part of the challenge is that the SBIGUDRV universal driver will be running and it likely wants to give 1 program control of both cameras OR alternatively, the USB bus is tied up when one is downloading images (the big camera), and the ST-IC doesnt respond as the bus is being hogged or something like that.

    Am not sure if those other programs are compatible with each other in this scenario.
     

Share This Page