Resolved Connecting to ZWO camera via MaxIm DL Pro on Mac - problems

Discussion in 'General' started by AlexInFlorida, Mar 24, 2020.

  1. AlexInFlorida

    AlexInFlorida Cyanogen Customer

    Joined:
    Mar 22, 2020
    Messages:
    8
    I installed the ASCOM platform, ZWO ASI Camera ASCOM drivers, then installed the MaxIM DL Pro application, on Windows 10 that's running in Parallels on my super-fast MacBook Pro. Well, it doesn't connect to the camera. Having a Windows laptop nearby, I did the same thing, and obviously it worked. Does anyone know what settings/configuration I need to modify, or whatever else I need in order to get this working within Parallels? I know -- bootcamp will solve the problem, but I don't want to run Windows on the Mac natively, hence why I have Parallels.
     
  2. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    2,965
    First off, please register for software support. See step #2 of:
    https://forum.diffractionlimited.com/pages/TechSupportHowTo/

    Secondly, we'd need a lot more information than that.. such as versions of everything you are using, and that's not a supported configuration.
    Now, that said, Parallels sometimes needs to be told to support USB3.0.
    And a lot of ZWO cameras work better at USB2.0 than 3.0. Change the cable between the ZWO and the computer and see if it works.
     
  3. AlexInFlorida

    AlexInFlorida Cyanogen Customer

    Joined:
    Mar 22, 2020
    Messages:
    8
    OK, thanks for the link. I submitted the registration info. I hope that helps.
    Version numbers -- well, I have the latest of everything -- Windows 10 Pro OS build 18363.752, running inside of Parallels Desktop for Mac Home Edition version 15.1.3 (47255). Mac OS is Catalina version 10.15.3. ZWO Camera model 533, which I purchased about 2 months ago. ASCOM Platform 6.4. I'll change the cable to be a standard USB 2.0 cable (black ends, not blue) and I'll let you know if that works better.
     
    Last edited: Mar 24, 2020
  4. AlexInFlorida

    AlexInFlorida Cyanogen Customer

    Joined:
    Mar 22, 2020
    Messages:
    8
    Well, looks like changing it from the USB 3 cable (with blue ends) to a USB 2 cable (with black ends) seems to have worked. Windows running in Parallels is now seeing the device. I am able to do a continuous image capture. Woohoo! OK, so next question -- when I do the camera control / exposure preset / 1 second continuous ... it says "Dark frame required; please cover the camera", and then "please uncover the camera". Hate to ask, but do I need to unscrew the camera and cover it? Is this required each time I use the software?
     
  5. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    6,576
    It's doing that because Auto Dark is enabled by default. Turn it off. Options menu.

    Note that the default Exposure Presets are just examples - tailor them for how YOU use the camera.

    Also, please register for software support, per Colin's earlier message.
     
  6. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    2,965
    BTW the switch to USB 2.0 is something I suggested because I've seen the same issue with another ZWO model running USB3.0 on a really fast PC on Windows. I suspect their hardware/firmware/low level drivers/ASCOM, but can't prove it. And it has been confirmed with third party software as well.
     
  7. AlexInFlorida

    AlexInFlorida Cyanogen Customer

    Joined:
    Mar 22, 2020
    Messages:
    8
    Switching to a USB 2.0 cable, and connecting it to the computer while it was running Windows inside of Parallels so that the Mac recognized the device being plugged in, did the trick. It's now recognizing the camera, and works great! So I guess it does work :)
     

Share This Page