Error connecting to serial port

Discussion in 'Specialty Cameras (ST-I, SG-4, AllSky)' started by Ryan M., Feb 7, 2020.

  1. Ryan M.

    Ryan M. Standard User

    Joined:
    Feb 7, 2020
    Messages:
    1
    I have recently been trying to work with your AllSky-340 camera but have not been able to successfully set it up. There seems to be an issue with the communication of the camera to the computer through the RS-232 cable. During set up, when I run the serial port test for any number of COM port numbers, an error message displays saying "error opening serial port". I tried connecting to multiple computers and also tried using a RS-232 to USB adapter but I haven't been able to get the camera to connect. I also tried resetting the baud rate on the camera to a slower setting but that also didn't work. Is there anything else I can try or do you think there is an issue with the cable or port? Let me know what you think and what I can do to get the camera to connect.
     
  2. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    6,480
    It's after hours here so we may not be able to resolve this until Monday.

    What is the serial number on your unit? Have you used it before?
     
  3. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    2,754
    Ryan, check the Windows Device Manager for LPT and COM ports. Under the COM ports, they should list what the Port number is. eg. COM3:, COM11:, etc.

    If you are using a USB to RS232 adapter, we recommend units with an FTDIchip chipset, NOT the ones with Prolific PL2303 as there have been problems with them historically. Check you have the latest device drivers from the manufacturer website, and check the Advanced Settings for the COM port, and turn OFF Serial Enumeration and windows power management/USB Selective Suspend.
     

Share This Page