Resolved Failed Firmware update, no longer connects to TSX or anything

Discussion in 'STT Series' started by Wannaberocker, Sep 19, 2021.

  1. Wannaberocker

    Wannaberocker Cyanogen Customer

    Joined:
    Nov 11, 2016
    Messages:
    61
    Location:
    Minnesota
    Hopefully this is repairable...I had a failed firmware update occur and now no matter what I try to do, my STT8300 no longer connects to anything, TSX, the driver checker, CCDOPS, nothing. My windows PC will recognize that there is an SBIG USB Camera connected in the device manager. The fans aren't turning. I hear just a relay click and the 1st Green and second Amber LEDS are illuminated.

    Can this be fixed easily or do I need to send this in for a repair? Thanks.
     
  2. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    5,370
    Location:
    Earth
    Wow - sorry to hear this. Usually they are pretty hard to brick.
    It might be fixable remotely.
    I think it's best for you to contact @Bill via bill (at) sbig (dot) com so he can comment.

    A couple of questions for you:
    1. Were you experiencing an issue, which is why you decided to update the firmware? (Just trying to understand the motivation).
    2. Was the firmware update interrupted? eg power failure, PC reboot, angry racoon jumping on your keyboard?
    3. To recover from this situation, did you try powering off the camera and PC and trying again?
    4. Were you running off AC power supply or something else?
    5. Which version of sbigudrv.dll do you have? (eg 4.99 build 7 is really solid - no need to update from that).

    Thanks
    Colin
     
  3. Adam Robichaud

    Adam Robichaud Lead Developer Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    899
    Location:
    Ottawa
    We can attempt a remote repair of your camera via TeamViewer. Please send me your connection details in a private message and I'll see what I can do.
     
  4. Wannaberocker

    Wannaberocker Cyanogen Customer

    Joined:
    Nov 11, 2016
    Messages:
    61
    Location:
    Minnesota
    I am done with work at 4pm. I’d like to try this. I have team viewer installed and ready to go. I will contact you after 4pm. Thanks.
     
  5. Wannaberocker

    Wannaberocker Cyanogen Customer

    Joined:
    Nov 11, 2016
    Messages:
    61
    Location:
    Minnesota
    I had an issues during shooting darks 1800” it would just stop during the run. I had seen I was not up to date my with the updates. I ran a firmware update and it looked like the driver checker program froze up so I disconnected and restarted everything and tried again. I now cannot connect to the camera with SBIG driver checker.
     
  6. Adam Robichaud

    Adam Robichaud Lead Developer Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    899
    Location:
    Ottawa
    I was able to log in and reflash the camera, as well as update the camera to the most current firmware.
    As I mentioned in our private thread, please power-cycle the camera at your earliest convenience to make sure the firmware is correctly loaded in memory.
    Closing the ticket as resolved. Let us know if you experience any further issues.
     
  7. Wannaberocker

    Wannaberocker Cyanogen Customer

    Joined:
    Nov 11, 2016
    Messages:
    61
    Location:
    Minnesota
    Perfect! This did the trick and I am now operational again! Thanks so much!
     
    Last edited: Sep 21, 2021

Share This Page