Failure of Three New STXL cameras with AOX and self-guiding filter wheel

Discussion in 'STX and STXL' started by Joseph Brimacombe, Sep 9, 2019.

  1. Joseph Brimacombe

    Joseph Brimacombe Standard User

    Joined:
    Feb 8, 2019
    Messages:
    7
    Please, can anyone help!

    About two years ago I purchased three STXL cameras (2 x STXL-6303 and 1 x STXL-11000) plus AOX and self-guiding filter wheels from OPT.
    They remained in their pelican cases until the weekend when I decided it was high time I upgraded my old STL cameras (6303 and 11000) even though they were still working fine. My obseratory is Savannah Skies Observatory near Chillagoe in Australia.
    1. The first STXL-6303 would not power up at all - will send this to Bill Lynch for repair. Obviously a hardware issue.
    2. The second STXL-6303 + SGFW + AOX powered up fine and when connected to Sky X (with all the latest drivers and firmware) cooled easily and the filterwheel worked fine, but when attempting to take an image the shutter failed. Sky X said there was a shutter driver error - 30017. I was subsequently unable to rotate the filterwheel or take a photo.
    3. The STXL-11000 + SGFW + AOX powered up fine, but when connected to Sky X (with all the latest drivers and firmware) after about 30 seconds, the cooling fan sped up for a few seconds and then the temp readings went offline. I was subsequenlty unable to rotate the filterwheel or take a photo. Sky X said there was a variety of driver errors - Operating System or Filterwheel - or it simply froze mid image with no error statement.
    These problems happened repeatedly using different computers and different camera control software (Maxim DL).
    Oddly, at one point I tried a slightly older driver with the STXL-11000 - Sbigudrv 4.90 build 1. This time it cooled perfectly and the filterwheel worked perfectly (which it did not do with the latest build), but then it failed from a shutter error that was identical to the STXL-6303 driver error.
    Am sure this is a driver issue, but what do I do next. I've tried everything.
     
  2. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    2,287
    First off, take a deep breath.
    We'll get you sorted.

    Did you check the cameras when you initial received them 2 years ago? Did you contact your dealer (OPT)? Any reason you didn't buy them from a local Australian Dealer (ATS or Bintel) ?
    How were they stored? eg at 22C room temperature or Aus heat outside?

    Please provide a list of serial numbers for all of the equipment.
    We'll also want proof of purchase - a scan of the invoice.
    Don't send anything until authorized.

    Problem 1: Power
    1. Did you try the power supply from another STXL with this first STXL6303 to see if it would power up?
    It could be the power brick or a fuse, simple to fix.

    Problem 2: Shutter
    This could have a number of possible causes. Let's eliminate drivers/firmware first, as there have been improvements made.

    1. Download the latest SBIG Driver Checker from the camera download page. Whatever was on the USB stick provided with the camera is now obsolete.
    Get it here: ftp://ftp.sbig.com/pub/SetupDriverChecker64.exe

    2. Check if the firmware is current as well, using the Firmware tab in the SBIG Driver Checker.

    3. After updating drivers and firmware, try it with CCDOps after you've updated the drivers (also available on our website).

    4. If you get the same error, then @Bill may need to be involved.

    Problem 3.
    Do the drivers and firmware first, as outlined above.

    Let us know what you find.
     
  3. Joseph Brimacombe

    Joseph Brimacombe Standard User

    Joined:
    Feb 8, 2019
    Messages:
    7
    Hi Colin
    So nice to get your prompt reply.
    When I purchased them (different times during 2016/17), I only checked that the STXL-11K powered up, neither STXL-6303s were checked.
    None of them were tested.
    They were all stored in an air conditioned environment.
    I have been using OPT to purchase almost all of my gear since 2004. I have a very good relationship with them and am a loyal customer.
    The are fast, reliable, well-stocked and extremely helpful in giving advice.
    Problem 1
    The power brick worked fine on the other cameras, and it failed with other power bricks.
    Problem 2 + 3
    I already updated the firmware and software on both cameras but had the same issues. I also tried to run it on Maxim but had the same issues. Will try CCDOps as you suggested.
    Am getting copies of the invoices from OPT and will sort out the serial numbers.
    Best wishes
    Joe.
     
  4. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    2,287
    Problem 1:
    Disconnect everything from the camera (filter wheel, ao, usb, power cable, guider cable, etc.)
    Check the internal fuse (it's an Automotive style fuse in the lower right rear corner of the circuit board.
    See Page 14 or so in the manual,
    Section 1.13 Opening the Back Cover - Changing the Fuse
    You can remove the fuse gently, and test it with an ohmmeter / continuity meter AFTER removing it.
    If the fuse is bad, then replace it with the same type and value.
    If the fuse is good, reseat it, close up the camera back, and try powering it up again.

    The power supplies come with an "extension cord" to go from the 3ft/1m DC power side of the power brick.
    Did you try another extension with the original suspected-faulty brick?
    It could be the extension is faulty.

    Problem 2+3:
    Thanks for that.
    We'll need the serial numbers to figure out next steps.
     

Share This Page