Resolved Filter Wheel Stop Position

Discussion in 'STC Series CMOS' started by Oscar Echeverri, Jul 19, 2021.

  1. Oscar Echeverri

    Oscar Echeverri Cyanogen Customer

    Joined:
    Sep 2, 2020
    Messages:
    15
    Location:
    White Lake, Ontario
    Hello,

    I noticed that the filterwheel on my STC-7 doesn't park the filters quite in the right spot.. it's off by a couple of degrees. You can see in the attached image, with the opaque position, that it's off a handful of degrees this happens at all filter positions.. it's not too much, and to be honest, I'm not sure whether or not it's impacting my images. I do have some vignetting in my flats that looks like it could coincide with the angle offset of filter position... but it's hard to say.

    Any thoughts on what might cause this or how I might be able to resolve it?
     

    Attached Files:

  2. KrisW

    KrisW Staff Member

    Joined:
    Feb 10, 2016
    Messages:
    4
    Hi Oscar,

    Thank you for bringing it to our attention and sorry for your trouble. I looked into this issue and was able to fix it. The solution is to update your camera's firmware to Rev 7. Please use the attached file and update your camera. Let me know if that solves your problem. Once you confirm, we will officially release the firmware to our website.

    As a bonus, this firmware speeds up image download by 33%. You probably won't be able to see the difference because in 1x1 full frame image it's only a 30ms drop from 90ms to 60ms. But still, the faster, the better, right?

    Kris
     

    Attached Files:

    Tim Povlick likes this.
  3. Oscar Echeverri

    Oscar Echeverri Cyanogen Customer

    Joined:
    Sep 2, 2020
    Messages:
    15
    Location:
    White Lake, Ontario
    Looks like the firmware update fixed it. Thanks!
     

Share This Page