Staff Assigned: Adam Robichaud Linux drivers for arm v8 64bit

Discussion in 'Scripting and Programming' started by Stefan Baar, Sep 5, 2019.

  1. Adam Robichaud

    Adam Robichaud Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    776
    Location:
    Ottawa
    I've added a note about the GLIBC dependency and Ubuntu 16.04 to our issue tracker. I compiled the package on Ubuntu 18.04 LTS, so if it's not working on that, I'm admittedly surprised. Can you confirm that?
     
  2. Jasem Mutlaq

    Jasem Mutlaq Standard User

    Joined:
    Dec 5, 2014
    Messages:
    14
    You built the armhf library on Ubuntu 18.04 on raspberry pi? GLIBC indicates the version in Debian Buster.
     
  3. Adam Robichaud

    Adam Robichaud Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    776
    Location:
    Ottawa
    Derp. Sorry, you're right. I was thinking of the x86/x64 builds. I built armhf on the latest Raspbian image. That I can investigate.
     
  4. Steve McKinney

    Steve McKinney Standard User

    Joined:
    Jul 15, 2016
    Messages:
    4
    Hi Adam,

    This issue is causing me trouble using the 32 bit drivers drivers with the SkyX on my Ubuntu-Mate 16.04 Raspberry Pi 3B+ (although is works on my Raspberry Pi 4 with Raspbian Buster). Is it possible to compile on an older bistro as Jasem suggested so that it's compatible with more versions (and my :) ) version of Linux?

    Thanks,

    Steve
     
  5. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    3,596
    This isn't really a priority for us right now due to other commitments and the current extraordinary circumstances.
     

Share This Page