Resolved Maxim DL evaluation software crashes with Canon EOS in Live View

Discussion in 'Demo User Tech Support' started by Kalpesh Jasapara, Apr 23, 2020.

  1. Kalpesh Jasapara

    Kalpesh Jasapara Standard User

    Joined:
    Apr 23, 2020
    Messages:
    13
    Hello,

    I am trying to get comfortable with Maxim DL with the Canon 550D (T2i) Modified, later planning to use it with SBIG Aluma.

    When I start the live view with the T2i, the Maxim DL demo software crashes and I have to restart. There are no error messages or any logs. Can you help?

    Is it it an issue with the Live View, I would love to try it with the Mac too however the demo software is an exe. Do you have a downloadable MAC version?

    Thank you for your time.
     
  2. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    3,590
    We don't have a Mac version. Some people have used MaxIm with Parallels on the Mac, however that's not officially supported.

    Regarding the problem with Live View, here are some things to check:
    Make sure Canon EOS Utility is not running in the background on your machine.
    Make sure you quit out of it, and that it does not automatically launch when you connect/power on the camera.
    Only one program can talk to the camera at a time.
    Like this:
    eos_utility_quit.png
    Make sure you have the correct setup for the camera:
    eos_setup.png
    I've change the mirror settle time, you may want to adjust.

    Make sure you have checked any option settings for this particular camera:
    eos_camerasettings.png
    Check that the mirror lockup settings are consistent.

    Check that you have the latest firmware for that camera. I believe it is 1.1.0 from 2016.
     
  3. Kalpesh Jasapara

    Kalpesh Jasapara Standard User

    Joined:
    Apr 23, 2020
    Messages:
    13
    Hey Colin,

    Thank you for your reply and instructions.
    I had version 1.0.9, which I updated now to 1.1.0.

    I have confirmed EOS utility is not launched, also verified with uninstalling the EOS utility.
    I have verified various combinations of the settings, i am able to get pictures in "Raw Monochrome" mode, the problem of Maxim DL crash happens when in "Live View" (for Readout Mode).

    BTW, the expose --> Options --> Camera settings is greyed out in my case.
    I have no problems getting live view to function with the same camera in EOS Utility, SGP and APT.

    Appreciate all your help.

    with regards,
    -Kalpesh
     
  4. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    3,590
    Does the Canon EOS Utility work on its own?
     
  5. Kalpesh Jasapara

    Kalpesh Jasapara Standard User

    Joined:
    Apr 23, 2020
    Messages:
    13
    Hello Colin,

    Thank you again for your reply.

    Yes that is correct, "Live View" works nicely with EOS Utility with both firmware version 1.0.9 and 1.1.0.

    Are there any logs or any other debug information that would help you narrow down the issue?
    Would a video capture or a zoom session help with the same?

    with regards,
    -Kalpesh
     
  6. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    3,590
    What version of EOS Utility are you running?
    Have you tried changing the Canon DLLs from = Default to EOS Utility in the Camera setup?

    Event Viewer will have some details of the crash. Look for a Critical Error called Application Error, with MaxIm_DL.exe in the name.
    On Monday when we are back at work, we'll see if we have on of these old cameras and if we can test/reproduce it.
     
  7. Kalpesh Jasapara

    Kalpesh Jasapara Standard User

    Joined:
    Apr 23, 2020
    Messages:
    13
    Hello Colin,

    That fixes the problem.

    I was using EOS utility 2.14. So I downloaded the latest EOS Utility 3.9.0 (which reinstalls 2.14 also again -- no choice to replace).
    EOS Utility 3.9.0 does not recognize EOS 550D (T2i) when the camera is switched on and Readme clearly says it is not supported.

    I first tried running with the EOS DLLs as you suggested, however it defaults to the 3.9.0 DLL (Observed in the Event Viewere) and Maxim DL crashes immediately on connect. Windows allowed me to remove only the EOS Utility 3 only

    Subsequently I tried to run Maxim DL again with EOS DLLs and Live view. This works good, now I just have to wait for clear skies before the trial expires.

    Thank you again for all your help and quick replies. Have a great weekend.

    with regards,
    -Kalpesh
     
  8. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    3,590
    Thanks for letting me know. Have fun!
     

Share This Page