Resolved Problems calibrating Red Channel light frames only

Discussion in 'STX and STXL' started by Peter Brack, May 22, 2018.

  1. Peter Brack

    Peter Brack Cyanogen Customer

    Jan 19, 2018
    Hi Doug

    I posted this on the PixInsight forum but had no response. I just wanted to check it wouldn't be caused by a camera problem. The images look fine, and the ACP log I had checked with Bob who said it was fine. Unsure what is happening here. Will try and check it with MaxIm today


    I am using the BPP script. On the last two objects I have imaged using LRGB, I am having an issue with Image Calibration for the Red channel. It will work fine only if I take out the flat frames, so there seems to be an issue with them only.

    But when I compare the images, and the FITS headers for the Red flats, and to the LGB flats, there appears to be no difference.

    I had obtained the flats using ACP Sky Flats and hadn't previously had an issue, but am now.

    I get the same error message :

    Applying bias correction: master dark frame...

    Dark frame optimization thresholds:

    Td0= 0.00030316 (162416 px= 0.968%)

    Computing master flat scaling factors...

    Error: Zero or insignificant scaling factor for flat frame channel#

    0. (empty master flat frame image?)


    It will produce this whether I have a master flat, or the individual flat frames.

    In the FITS header for red, which is the same for the LGB there is :

    BITPIX 16

    BSCALE 1.0000000000000 ( or so)

    BZERO 32768.000000000

    I am using a master bias and master dark which work fine on the other channels.

    Unsure what is going on. Have tried it through Image Calibration instead but produces the same result.

    Any suggestions?

    Thank you.
  2. Doug

    Doug Staff Member

    Sep 25, 2014
    Can't comment on other people's software.

    If you post the images we can have a look. Upload FITS to, incoming folder.
  3. Peter Brack

    Peter Brack Cyanogen Customer

    Jan 19, 2018
  4. Peter Brack

    Peter Brack Cyanogen Customer

    Jan 19, 2018
    tried to calibrate with MaxIm, but the master dark has 0.00 sec on it but it was actually 600s and it brings up an error "no exposure duration was specified"
  5. Doug

    Doug Staff Member

    Sep 25, 2014
    However you generated the Master Dark, it has no EXPTIME keyword.

    Either regenerate it correctly (no idea what you did wrong - different software), or manually edit the FITS header to add the missing information.

    SIMPLE = T / file does conform to FITS standard
    BITPIX = -32 / number of bits per data pixel
    NAXIS = 2 / number of data axes
    NAXIS1 = 4096 / length of data axis 1
    NAXIS2 = 4096 / length of data axis 2
    EXTEND = T / FITS dataset may contain extensions
    COMMENT FITS (Flexible Image Transport System) format is defined in 'Astronomy
    COMMENT and Astrophysics', volume 376, page 359; bibcode: 2001A&A...376..359H
    PROGRAM = 'PixInsight' / Software that created this HDU
    COMMENT PixInsight Class Library: PCL
    COMMENT FITS module version
    COLORSPC = 'Grayscale' / PCL: Color space
    RESOLUTN = 72. / PCL: Resolution in pixels per resolution unit
    RESOUNIT = 'inch ' / PCL: Resolution unit
    THUMBIMG = 'Thumbnail' / PCL: File includes thumbnail image extension
    OBSERVER = 'Peter Brackenridge' / Observer who acquired the data
    INSTRUME = 'SBIG STX-16803 3 CCD Camera' / Name of instrument
    IMAGETYP = 'Dark Frame' / Type of integrated image
    FILTER = 'Lum ' / Name of filter
    BINNING = 1. / Pixel binning factor
    XORGSUBF = 0. / Subframe origin, X axis
    YORGSUBF = 0. / Subframe origin, Y axis
    TELESCOP = 'Alluna RC18' / Name of telescope
    FOCALLEN = 3726. / Effective focal length in mm
    APTDIA = 4572. / Effective aperture diameter in mm
    APTAREA = 164173. / Effective aperture area in square mm
    COMMENT Integration with PixInsight
    HISTORY Integration with ImageIntegration module version
    HISTORY Integration with ImageIntegration process
    HISTORY ImageIntegration.pixelCombination: average
    HISTORY ImageIntegration.outputNormalization: none
    HISTORY ImageIntegration.weightMode: don't care
    HISTORY ImageIntegration.scaleEstimator: iterative k-sigma / BWMV
    HISTORY ImageIntegration.pixelRejection: percentile clipping
    HISTORY ImageIntegration.rejectionNormalization: none
    HISTORY ImageIntegration.numberOfImages: 5
    HISTORY ImageIntegration.totalPixels: 83886080
    HISTORY ImageIntegration.totalRejectedLow: 4(0.000%)
    HISTORY ImageIntegration.totalRejectedHigh: 10307(0.012%)
    HISTORY ImageIntegration.scaleEstimates_0: 1.3258e-04
    HISTORY ImageIntegration.locationEstimates_0: 1.5946e-02
    HISTORY ImageIntegration.imageWeights_0: 1.00000e+00
    HISTORY ImageIntegration.zeroOffsets_0: +0.000000e+00
    HISTORY ImageIntegration.rejectedLow_0: 1
    HISTORY ImageIntegration.rejectedHigh_0: 2142
    HISTORY ImageIntegration.scaleEstimates_1: 1.3301e-04
    HISTORY ImageIntegration.locationEstimates_1: 1.5930e-02
    HISTORY ImageIntegration.imageWeights_1: 1.00000e+00
    HISTORY ImageIntegration.zeroOffsets_1: +1.525879e-05
    HISTORY ImageIntegration.rejectedLow_1: 2
    HISTORY ImageIntegration.rejectedHigh_1: 1951
    HISTORY ImageIntegration.scaleEstimates_2: 1.3318e-04
    HISTORY ImageIntegration.locationEstimates_2: 1.5930e-02
    HISTORY ImageIntegration.imageWeights_2: 1.00000e+00
    HISTORY ImageIntegration.zeroOffsets_2: +1.525879e-05
    HISTORY ImageIntegration.rejectedLow_2: 0
    HISTORY ImageIntegration.rejectedHigh_2: 2196
    HISTORY ImageIntegration.scaleEstimates_3: 1.3338e-04
    HISTORY ImageIntegration.locationEstimates_3: 1.5915e-02
    HISTORY ImageIntegration.imageWeights_3: 1.00000e+00
    HISTORY ImageIntegration.zeroOffsets_3: +3.051944e-05
    HISTORY ImageIntegration.rejectedLow_3: 1
    HISTORY ImageIntegration.rejectedHigh_3: 1901
    HISTORY ImageIntegration.scaleEstimates_4: 1.3304e-04
    HISTORY ImageIntegration.locationEstimates_4: 1.5915e-02
    HISTORY ImageIntegration.imageWeights_4: 1.00000e+00
    HISTORY ImageIntegration.zeroOffsets_4: +3.051944e-05
    HISTORY ImageIntegration.rejectedLow_4: 0
    HISTORY ImageIntegration.rejectedHigh_4: 2117
    INPUTFMT = 'FITS ' / Format of file from which image was read
  6. Peter Brack

    Peter Brack Cyanogen Customer

    Jan 19, 2018
    That's interesting. I just Calibrated them in Pixinsight and that is how they turned out.

    Am unsure how to write in the exposure time into FITs

    I just calibrated the Flat frames in MaxIm instead, and then used the Master Flat into the ImageCalibration and Batch processing script in Pixinsight and it worked okay. So there is something that is going wrong with the creation of the Red Master Flat in Pixinsight that seems to be the problem. Unsure what to about that. Maybe I will start calibrating in MaxIm from now on. It's certainly simple to do

  7. Doug

    Doug Staff Member

    Sep 25, 2014
  8. Bob Denny

    Bob Denny Cyanogen Customer

    Oct 12, 2014
    DC-3 Dreams, SP, Mesa, Arizona +1 480 396 9700
    My suggestion (I’m not a Diffraction employee) is to calibrate in MaxIm exclusively. It does a fantastic job, and the calibration wizard is brilliant simple to use. Once you have calibrated images, move on to the fancy stuff in whatever other software.
  9. William B

    William B Cyanogen Customer

    Jan 8, 2015
    Christchurch, Dorset UK

    In addition to the advice given above there are a couple of other issues with your files in the dropbox.

    In PixInsight > Edit > Global Preferences > File I/O settings, deselect 'Enable thumbnail embedding by default' as this confuses other image calibration software that do not know how to handle embedded thumbnails. It also makes working in PI very tedious when thumbnails keep popping up when opening images. When you save an image you have the option of embedding a thumbnail if you want to, look for the checkbox in the save file dialogue, but unless you think it is needed then don't bother and certainly don't use the default option of automatically embedding.

    I have found that taking PI calibration masters into other vendors software rarely works properly first time, there are just too many save options within PI that have to be chosen just right for the package you are exporting to.

    However, I was able to calibrate your sample red channel image in PI, using both the BPP script and the stand alone Calibration Tool.

    In BPP when using previously created masters the check boxes must be selected to signify that masters are to be used, the default on opening or resetting the tool is that these are deselected.
    Click image below to view in full resolution.

    PI Use Masters in BPP.jpg

    In the stand alone calibration tool when using existing masters the check box 'Calibrate' must be selected under 'Master Dark', the default on opening or resetting the tool is that this is deselected.
    Click image below to view in full resolution.

    PI Use Masters in Cal.jpg


    Last edited: May 25, 2018

Share This Page