Staff Assigned: Bill Lynch SBIG STF 8300 Filter Wheel 8 positions

Discussion in 'Filter Wheels' started by Muhammad Ali, Mar 19, 2019.

  1. Muhammad Ali

    Muhammad Ali Standard User

    Joined:
    Mar 19, 2019
    Messages:
    3
    Recently I unboxed SBIG package and attach Filter Wheel, autoguider, Camera cables as instructed in Manual. I re-installed CCD Ops software, SBIG drivers 20190318_203742.jpg 20190318_204138.jpg 20190318_220655.jpg 20190317_110236.jpg 20190318_203742.jpg 20190318_204138.jpg also but Filter Wheel is dead silent, when I try to use it gives attached Error shots. Is it software problem or hardware, I also want to mention here that it dropped on the floor and hit the ground from an edge, Camera is working fine, autoguider is responding but filter wheel is dead silent.
     
  2. Bill

    Bill SBIG Service and Repairs Staff Member

    Joined:
    Oct 12, 2014
    Messages:
    415
    Did you happen to connect the filter wheel to the camera after the camera was already powered?

    -Bill
     
  3. Muhammad Ali

    Muhammad Ali Standard User

    Joined:
    Mar 19, 2019
    Messages:
    3
    Bill-Unfortunately YES
     
  4. Bill

    Bill SBIG Service and Repairs Staff Member

    Joined:
    Oct 12, 2014
    Messages:
    415
  5. Muhammad Ali

    Muhammad Ali Standard User

    Joined:
    Mar 19, 2019
    Messages:
    3
    Email sent to you.
    What would explain it?
     
  6. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    6,092
    Every camera ships out with a highly visible warning label:

    0.jpg
     

Share This Page