SBIG STT8300 USB timeout error

Discussion in 'STT Series' started by Wannaberocker, May 17, 2018.

  1. Wannaberocker

    Wannaberocker Cyanogen Customer

    Joined:
    Nov 11, 2016
    Messages:
    61
    Location:
    Minnesota
    I get this strange error intermittently and sometime not at all in an evening.

    SBIG driver: Transmission timeout. Error = 30007

    It gets reported in the log from CCD AutoPilot 5 using TSX. I am unsure where to start. Perhaps maybe too many hubs inline. The STT8300+FW8G+STT+AO-8T is connected to my Paramount MyT versa-plate port and then goes into a Kendrick Astro imaging power panel (the USB 3.0 Version) then to the PC with an active USB 3.0.

    Could this be related to the PC processor? or the Ram? I think I'll break this into steps, first step I will eliminate the versaplate and go straight from the STT8300 to the Kendrick Astro hub.

    Thanks for any help.
     
  2. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    8,538
    Prime suspect: USB connection. Avoid hubs as much as possible. If you have a separate guide camera definitely do not put both cameras on one hub. Avoid the USB jacks on the front of a desktop; their signal quality is compromised by the internal wiring.

    Secondary suspect: Power supply. Paramount internal wiring is insufficient gauge in my experience, especially at full cooler power. STT is not as high power consumption as STX/STXL, but it's still a possible cause of problems.
     
  3. Wannaberocker

    Wannaberocker Cyanogen Customer

    Joined:
    Nov 11, 2016
    Messages:
    61
    Location:
    Minnesota
    Thanks Doug I'll consider all of this. I am using the FW8G-STT and AO-8T for guiding so I cannot separate them as far as I know anyway. The camera power supply is a dedicated line ran through the mount with 16 gauge electrical cord and does not use the Bisque mount for power at all. I'll try bypassing the versaplate on the MyT and see how it goes.
     
  4. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    5,370
    Location:
    Earth
    Bypass the Versaplate - I think the hub they built in isn't quite up to muster due to the number of people having issues with it.
    Also, suggest you double check Windows Power Management - USB Selective Suspend is off for all USB devices, hubs, and USB Root Hubs.
     
  5. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    8,538
    With the FW8G-STT you don't need to worry about the guide camera.

    Nevertheless, USB hubs are frequently an issue. Colin's advice is good...
     
  6. Wannaberocker

    Wannaberocker Cyanogen Customer

    Joined:
    Nov 11, 2016
    Messages:
    61
    Location:
    Minnesota
    I bypassed the VersaPlate. The problem seems to have vanished for 2 whole sessions now. Thanks.
     

Share This Page