Resolved SBIGUDrv Tx Timeouts - Call for Beta Testers

Discussion in 'CCDOPS and SBIG Universal Driver' started by Adam Robichaud, Sep 15, 2016.

Thread Status:
Not open for further replies.
  1. Adam Robichaud

    Adam Robichaud Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    788
    Location:
    Ottawa
    We have identified a potential issue in SBIGUDrv that may be the root cause of some Tx Timeouts recently reported, but have been unable to reproduce the issue in-house. If you're experiencing regular Tx Timeouts when using your SBIG cameras in any program (MaxIm DL, CCDOps, The Sky X, etc), then we're looking for beta tester to help us identify the root cause, and test potential fixes.

    We'll be providing users with a special version of SBIGUDrv with increased logging features, and requesting logs which capture Tx Timeouts. Because this first driver is strictly for creating logs, we ask that you only apply if you are able to reproduce the issue reliably, and repeatably. Anyone able to run on a daily basis will be given priority.

    If you are able to participate in the tests, please leave a message below and I'll get in touch with an updated copy of SBIGUDrv, and instructions.
     
  2. Gerald R Miller

    Gerald R Miller Standard User

    Joined:
    Oct 27, 2014
    Messages:
    32
    Sign me up, please.
     
  3. Robert Mueller

    Robert Mueller Standard User

    Joined:
    Jun 22, 2015
    Messages:
    79
    Location:
    Sedona, Arizona
    Adam,
    I will test after my camera gets back from Service for another issue.
    Thanks,
    Robert Mueller
     
  4. Richard Asarisi

    Richard Asarisi Standard User

    Joined:
    Mar 5, 2016
    Messages:
    47
    I can test this for you - new OTA coming in another week or 2.
    i'm using TSX
     
    Last edited: Sep 15, 2016
  5. Adam Robichaud

    Adam Robichaud Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    788
    Location:
    Ottawa
    Just FYI, the package will likely go out tomorrow morning — documentation is almost complete.
     
  6. Kevin Morefield

    Kevin Morefield Standard User

    Joined:
    Jan 17, 2016
    Messages:
    39
    Adam,

    Yes, I have nightly disconnects with the STX. Please let me know what I need to do.

    Thanks,

    Kevin
     
  7. Adam Robichaud

    Adam Robichaud Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    788
    Location:
    Ottawa
    I've released a new version of SBIGUDrv (available via SBIG Driver Checker 64) which has increased logging capabilities. If you would like to do the test, you can update your drivers, and collect a few logs for us.

    For details on collecting logs, if you've never done it before, I've prepared a document available here: https://arobicha.gitbooks.io/sbigudrv/content/collecting-driver-logs.html

    Please forward me any logs you collect demonstrating the issue (You can zip the log files and upload them directly here).

    Cheers,
    -A
     
  8. Robert Mueller

    Robert Mueller Standard User

    Joined:
    Jun 22, 2015
    Messages:
    79
    Location:
    Sedona, Arizona
    Adam,
    Will this beta driver imapact STT8300M cameras? I also have one of them and I get fairly common timeout error with it.
    Thanks,
    Robert Mueller
     
  9. Adam Robichaud

    Adam Robichaud Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    788
    Location:
    Ottawa
    It will collect improved driver logs for it, yes, but it contains no fixes (the same as the STX(L) line). The improved logging is system-wide, and camera independent.
     
  10. Carlos D

    Carlos D Standard User

    Joined:
    Nov 2, 2014
    Messages:
    1
    is this for PC or Mac versions or both?
    thanks
    -C
     
  11. Adam Robichaud

    Adam Robichaud Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    788
    Location:
    Ottawa
    PC. I haven't had a chance to generate the OSX installer yet, and the issue we're investigating is specific to Windows systems. If you're experiencing a similar issue on OSX, can you send me a private message?
     
  12. Adam Robichaud

    Adam Robichaud Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    788
    Location:
    Ottawa
    Hi All,

    It's been 2 weeks and I haven't received any logs. Is the issue still occurring for people?

    Cheers,
    -Adam
     
  13. Kevin Morefield

    Kevin Morefield Standard User

    Joined:
    Jan 17, 2016
    Messages:
    39
    Adam,

    I sent you a note but didn't see a reply. When I downloaded the lasted driver checker it came back with an 8/4/16 date for the STX driver which was what I already had. I'd like to get the logging going, as I had another focus run fail last night.

    Let me know if I was looking for the wrong thing on the Driver!

    Thanks,

    Kevin
     
  14. Adam Robichaud

    Adam Robichaud Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    788
    Location:
    Ottawa
    Odd, I'm not seeing a note anywhere...

    According to the FTP server, the latest version of SBIGUDrv released to the public is 4.95 build 1 — which was released on September 21st, 2016. If you download and install the latest version of SBIG Driver Checker 64 from sbig.com, it will come with it — but you'll still need to press the "Update" button in order to have it install properly from within SBIG Driver Checker 64.
     
  15. Kevin Morefield

    Kevin Morefield Standard User

    Joined:
    Jan 17, 2016
    Messages:
    39
    Got it! I was expecting to see the new driver version in the driver window after I clicked "Update me" on the driver checker and before I clicked on update me warning window. It's done now and I'll turn on the logging.

    OK selected the default STX logging and added camera and USB. Good?
     
  16. Robert Mueller

    Robert Mueller Standard User

    Joined:
    Jun 22, 2015
    Messages:
    79
    Location:
    Sedona, Arizona
    Adam,
    I just got my camera back from the shop to fix another issue. Now waiting on weather.
    Thanks,
    Robert Mueller
     
  17. Martin Pugh

    Martin Pugh Cyanogen Customer

    Joined:
    Oct 27, 2014
    Messages:
    199
    Adam
    these are not recent logs, but I still had the emails when I sent two logs to Jan Soldan. However, one file is 3Mb and the website will not accept a file that big. As soon as I get a hang, I will upload more recent files.

    regards
    Martin
     

    Attached Files:

  18. Mark Manner

    Mark Manner Cyanogen Customer

    Joined:
    Oct 31, 2014
    Messages:
    12
    Location:
    Nashville, TN USA
    I can reproduce this problem within a few minutes. Please send driver to karenacollins@outlook.com .
    Regards,
    Karen Collins (for Mark Manner)
     
  19. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    3,745
    Martin -if the logs are too big, you can use FTP to transfer them up to the ftp.cyanogen.com site's incoming directory, or you could post them somewhere like dropbox.
     
  20. Mark Manner

    Mark Manner Cyanogen Customer

    Joined:
    Oct 31, 2014
    Messages:
    12
    Location:
    Nashville, TN USA
    Find a log file attached showing the TX Timeout error near the end of the file (search for "TX Timeout"). I have truncated the file shortly after the error, and part of the middle of the file before the error (marked by several blank lines and the break in the time stamp) to get it below 1 MB for upload. I still have the full original file if needed.

    I am using TSX Pro (v10.5.0) to control the STX-16803 with no AO connected at the moment running under Windows 7 Pro. The STX drivers and firmware have been updated to the most recent versions using the SBIG 64 bit Driver Checker Utility (see attached screen grabs).

    This problem is very difficult to duplicate with the logs enabled, apparently bec FirmwareInfo.JPG DriverInfo.JPG ause readout time is greatly slowed (maybe by a factor of 10x). If I turn logs off, I can duplicate the problem readily by using the "Focus Tools" settings in TSX, with the exposure time set to 1.0 seconds, exposure delay = 0.0 secs, 1x1 binning, a Subframe of 64x64 pixels, and saving of focus files disabled.

    If you have a beta version of a fix, I can quickly test it since I can duplicate the problem without the telescope being opened to the sky.

    Karen Collins (debugging for Mark Manner)
    Send email correspondence to karenacollins@outlook.com.
     

    Attached Files:

Thread Status:
Not open for further replies.

Share This Page