Staff Assigned: Bill Lynch ST-i Shutter

Discussion in 'Specialty Cameras SG-4, AllSky, ST-I' started by Paul Buirke, Apr 14, 2020.

  1. Paul Buirke

    Paul Buirke Cyanogen Customer

    Joined:
    Jun 20, 2015
    Messages:
    17
    My ST-i (sn# 12569) is also having shutter problems. Was working fine till last week then couldn't find any stars. Testing it out of the OAG with no power to the camera the shutter will open and close by tilting the camera. Connecting the USB the camera is recognized (Win 10 latest SBIG drivers and firmware in the ST-i), the shutter will still open and close by tilting the camera. Connect the ST-i to Maxim Dl (6.19) the shutter will cycle closed,open,closed, open and stay open, tilting the camera doesn't make a difference it stays open. Take a 2 sec image, No calibration, shutter closes and stays closed. Take a 2 sec image, simple auto-dark, the shutter opens for 2 sec (for the dark) then closes for the 2 sec exposure and remains closed. Disconnect from Maxim, the shutter stays closed (tilting has no effect). Unplug the USB and the shutter will open and close by tilting the camera.
    I can connect my ST-i c (#510230) and the shutter behaves normal. Help !
    ???
    Paul
     
  2. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    7,144
    @Bill can help you with this.
     
  3. Bill

    Bill SBIG Service and Repairs Staff Member

    Joined:
    Oct 12, 2014
    Messages:
    479
    Paul,

    Send me an email, bill@sbig.com, and I will give you the details for sending it in.

    -Bill
     

Share This Page