ST-i Won't Image

Discussion in 'Specialty Cameras SG-4, AllSky, ST-I' started by Stanley A. Gorodenski, May 10, 2019.

  1. Stanley A. Gorodenski

    Stanley A. Gorodenski Standard User

    Joined:
    May 10, 2019
    Messages:
    2
    I had to replace the hard drive in my laptop and so I am having to re-install everything again. It is a Lenovo i7. It has the same operating system before I replaced the hard drive, Win 7 Professional 64-bit. As part of the re-install of everything, I installed ver 6.3 of ASCOM.

    This is about the ST-i camera. The camera has not been in service for 6 months or so, but the last time I used it (on my spectrograph to guide with) it was working. I am guiding with CCDOPS.

    When I launch CCDOPS it recognizes the camera and gives me the information on it when I click on the button to get camera information. So, I know it is making contact with the camera. However, it will not take an image. I reran the Driver Checker64 with the camera plugged into the laptop. This involved downloading the drivers and updating them. It still will not take an image.

    I then removed all the drivers and again downloaded and updated them. It still will not take an image.

    I checked the Firmware and it says it is up to date. Previously I had re-installed CCDOPS from an older disk that came with my ST-8XME camera. Since it was an old disk, I then re-installed CCDOPS from the disk that came with the ST-i camera. It still will not take an image.

    I then tried taking an image using CCDSOFT. It made contact with the camera but it still will not take an image. I get the same uniformly black (gray after a dark sky subtract) that has no granulation from pixels. So, I know the problem is not with CCDOPS.

    Finally, I switched to another USB port on my camera, which shouldn't have made a difference because the camera is being recognized with the other USB port. It still will not take an image

    Could this be a shutter problem? It does not seem likely because the image is entirely and uniformly black, no granulation from the pixels at all. Does anyone have suggestions of what could be wrong?
     
  2. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    3,829
    I would suggest you start by downloading the latest SBIG driver Checker from here:
    ftp://ftp.sbig.com/pub/SetupDriverChecker64.exe

    Then download any driver updates and check the firmware - that confirms the computer is indeed talking to the camera.

    Next, get the latest CCDOPS from here:
    ftp://ftp.sbig.com/pub/InstOps.exe

    Can you look into the end of the camera and see if the shutter is actually moving? It is usually pretty obvious, you may need a bit of light like a desk lamp or something to see it swing in front of the sensor chip.
    A click is a good hint that it is working too.

    What happens if you take a DARK or BIAS? do you get noise?
    Can you post a sample FITS image - dark, bias, light ?

    If updated drivers and software don't solve it, it may need to be serviced. Our colleague @Bill can assist.
     
  3. Stanley A. Gorodenski

    Stanley A. Gorodenski Standard User

    Joined:
    May 10, 2019
    Messages:
    2
    Hi Colin,
    Thanks for your response. As I mentioned in my original post I had downloaded the latest DriverChecker64 and downloaded and updated the drivers. As I mentioned in my post, I also checked the firmware and it said it is installed. As I also mentioned in my original post the image it uniformly black with no granulation from pixels. There is no image noise or nothing. It is entirely and uniformly black. When I do a dark subtract in CCDSOFT it looks gray, not black, and it is a uniform gray, no granulation from the pixels at all. It would do no good to send an image because there is nothing in it to see. If you can imagine a surface painted black or gray that is what it looks like, like the uniformity of colors on a color card when choosing colors of paint. I do not hear a click of the shutter moving. I normally hear this. I prefer not to take the camera out of the spectrograph just to look at the shutter unless all other diagnostics fail because I have it adjusted for spectroscopy. At this point, it does not appear to be the shutter.

    I could download the latest version of CCDOPS but I do not think that is the problem because as I said in my post I cannot take an image with CCDSOFT either. I get the same result, a uniform black image, and a uniform gray one if I do a dark subtract with no noise or granulation from pixels.
     
  4. Bill

    Bill SBIG Service and Repairs Staff Member

    Joined:
    Oct 12, 2014
    Messages:
    479
    Stanley,

    Verify, if you can, that the shutter is moving. Try an "also" image in CCDOps, you should be able to hear the shutter clack back and forth. I suspect you won't. Regardless, even if the shutter is moving, it quite likely is going to have to come in. Send me an email, bill@sbig.com, and I'll give you the instructions for sending it in.

    -Bill
     

Share This Page