Trouble Running Sample VBScript

Discussion in 'Scripting and Programming' started by Lee Wizda, Oct 18, 2016.

  1. Lee Wizda

    Lee Wizda Standard User

    Oct 18, 2016
    I have been having trouble trying to run the simple example script included with Maxim DL install. When I run I get the following VBScript runtime error

    Error: ActiveX component can't create object: 'Maxim.CCDCamera'
    Code: 800A01AD

    I am running Maxim DL ver 4 on Windows 7 64 bit machine. I'm pretty sure the 64 bit machine is the cause of my problem. I have tried all the solutions offered elsewhere including,

    1. use the 32-bit version of cscript/wscript to run the VBScript. I get the above error code regardless if I use the 64 bit version or the 32 bit cscript/wscript

    2. Running the cscript with the 32 bit cmd.exe. This is essentially the same solution as 1. above

    3. I tried registering the .dll's with the 32 bit regsvr32 but I get
    The module "..\xxx.dll" was loaded but the entry-point DllRegisterServer was not found.

    Does anyone have any idea what can be causing the problem? Below is the code.
    I am willing to purchase Maxim ver 6, but is it a 64 bit application. I might try to find a 32 bit machine somewhere here to see if I can get it to work.

    Dim cam ' "The" Camera object

    Set cam = CreateObject("MaxIm.CCDCamera")
    cam.LinkEnabled = True
    if Not cam.LinkEnabled Then
    wscript.echo "Failed to start camera."
    End If

    cam.Expose 1, 1, 0

    Do While Not cam.ImageReady
    ' Don't consume CPU time while waiting
    wscript.sleep 100
    cam.SaveImage ""
  2. Doug

    Doug Staff Member

    Sep 25, 2014
    MaxIm DL works just fine on 64-bit computers - actually better than on 32-bit computers. In fact, all the computers used for software development are 64-bit.

    It sounds like MaxIm DL isn't COM registered properly. Right-click on the program icon and select Run As Administrator - just the one time. That will allow it to register itself. Then close the software.

    Now try running the script.
  3. Lee Wizda

    Lee Wizda Standard User

    Oct 18, 2016
    Thanks for your quick response. I installed the trial version of ver. 6.13 before I saw your reply. I cannot test your suggestion now, as after I installed the trial version my Ver. 4 program was able to run scripts. I will try to test it out on my lab computer when I get a chance to see if that resolves the issue. I will probably just update our computers with the latest version ultimately, but it would be good to know if that solves the issue in case any one else runs into this problem.

Share This Page