Windows 10 Drivers for Apogee Alta U16M camera

Discussion in 'Off Topic' started by Dave Mussell, May 11, 2020.

  1. Dave Mussell

    Dave Mussell Standard User

    Joined:
    May 11, 2020
    Messages:
    3
    Hi all,
    Does anyone out there have working Windows 10 drivers for the Apogee U16M 16803-based camera? If not, how about Windows 7? I have this camera and would really like to use it with an up-to-date computer (Windows 10) but would happily settle for getting it to run on an older W7 computer I have that has an older version of SGP on it. Andor / Cambridge no longer offers this camera and has not updated the driver set for it as a legacy item. Any help anyone can offer would be deeply appreciated.
    Dave Mussell
    Alberta Canada
     
  2. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    4,051
    I'm pretty sure the old drivers work fine on Win 10. I went through this with another customer, but I can';t remember who it was.
     
  3. Dave Mussell

    Dave Mussell Standard User

    Joined:
    May 11, 2020
    Messages:
    3
    Thanks for the quick response Colin! I have read forum posts elsewhere where respondents reported success with the U16M on W10 using original Apogee drivers, which is encouraging given that this is an expensive piece of kit capable of incredible images and well worth resurrecting.

    For the information of members of this forum, I notice that my copies of SharpCap, SGP and NINA stumble in the connection process when they request the read modes from the U16M. The ASCOM drivers I have which I think are the last ones that were available from Andor do not seem to be able to report the read mode(s) in a way those packages are expecting so process of linking to the camera stops there. There may be other fails waiting to be discovered further down in the connection process but in my case, they get stuck there. I have an old version of Nebulosity that runs on a Windows 7 Ultimate laptop that will mount the camera successfully but that is hardly a solution since I lose a lot of other functionality on that machine with respect to automation (focusing, plate solving, etc.).

    So my hope was that since DL once supported Apogee cameras and filter wheels, someone there would have maintained the latest working ASCOM drivers for the U16M. I would want to know if they are different or more up-to-date than mine. In addition, I'd be willing to buy MaximDL to run this camera if I was confident that software would manage the camera connection successfully. I have an old version of it on an optical disk with the coil-bound printed manual somewhere but haven't located it yet.

    I will re-test the W10 connection process more carefully to make sure I've got a working combination of drivers, software settings, and operating system configuration. I'll touch base again if I can't make further progress. I have also emailed Cambridge for help on this.
     
  4. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    4,051
    Dave, mailing Cambridge won't help (hee hee). It's Oxford Instruments that owns Andor. You've confused 2 universities.
    I recall we had to get the Andor Apogee control program as well to test the camera was being seen correctly. Sometimes it was coming up as the wrong device (a filter wheel or something) due to an error in their code and driver versions.
    From my notes I see:
    AndorDriverPack2Setup-2.104.30000.0
    apgSwInstall-x86
    ApogeeAscomDriver.5.5.4
    I seem to recall the ASCOM driver did not work right.

    You can get a 30 day demo of MaxIm and try it out. Go to the MaxIm DL Pro page, and click on the Blue DEMO tab.
    https://diffractionlimited.com/product/maxim-dl/

    Other threads on the Apogee topic:
    https://forum.diffractionlimited.com/posts/36705/
    https://forum.diffractionlimited.com/posts/32383/
    https://forum.diffractionlimited.com/posts/32462/
    https://forum.diffractionlimited.com/posts/34385/
     
  5. Eric Jensen

    Eric Jensen Cyanogen Customer

    Joined:
    May 2, 2017
    Messages:
    7
    This thread is a few months old, but I came across it as I'm installing a new observatory computer for the first time in 8 years, and thus trying to get our old Apogee U16M camera and AFW50-10S filter wheel working under Windows 10. I was unsuccessful in finding drivers to download online - as far as I can tell, Oxford Instruments has abandoned these completely. (To be fair, I didn't email their support, but I did try to do a pretty thorough search of their website, and found no hint of drivers there.) Fortunately, thanks to Colin's post just above this, knowing the name of the driver installer (apgSwInstall-x86) enabled me to track down a copy of it (circa 2013) on my old computer - I guess that's an argument for not cleaning out your Downloads folder! :)

    Those drivers installed fine under Windows 10, and once they were installed, Windows detected the camera and filter wheel, and it was no problem to set them up in MaxIm DL as usual.

    In case it's useful to anyone, I've documented my install procedure here, including a link to that driver installer package. Given that it doesn't appear to be available online any more from the manufacturer, I'll plan to keep it there for the time being.

    Hope this helps someone -

    Eric
     
  6. Dave Mussell

    Dave Mussell Standard User

    Joined:
    May 11, 2020
    Messages:
    3
    Eric,
    This is very encouraging. Thanks for posting your progress. I was about to give up on the Apogee camera. The FW I have is visible to W10P and operates just fine under almost any camera control software I can think of, but my favourites, SGP and NINA both get stuck when they try to get the read mode from the camera. I was hoping NOT to use MaximDL (an old dog here trying not to have to learn new tricks) but perhaps I have no choice. I'll give your installation instructions a go and see where that takes me. It would be a shame not to have the use of this amazing camera.

    Dave
     

Share This Page