Windows 10 Drivers for Apogee Alta U16M camera

Discussion in 'General' started by Dave Mussell, May 11, 2020.

  1. Dave Mussell

    Dave Mussell Standard User

    Joined:
    May 11, 2020
    Messages:
    2
    Hi all,
    Does anyone out there have working Windows 10 drivers for the Apogee U16M 16803-based camera? If not, how about Windows 7? I have this camera and would really like to use it with an up-to-date computer (Windows 10) but would happily settle for getting it to run on an older W7 computer I have that has an older version of SGP on it. Andor / Cambridge no longer offers this camera and has not updated the driver set for it as a legacy item. Any help anyone can offer would be deeply appreciated.
    Dave Mussell
    Alberta Canada
     
  2. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    3,453
    I'm pretty sure the old drivers work fine on Win 10. I went through this with another customer, but I can';t remember who it was.
     
  3. Dave Mussell

    Dave Mussell Standard User

    Joined:
    May 11, 2020
    Messages:
    2
    Thanks for the quick response Colin! I have read forum posts elsewhere where respondents reported success with the U16M on W10 using original Apogee drivers, which is encouraging given that this is an expensive piece of kit capable of incredible images and well worth resurrecting.

    For the information of members of this forum, I notice that my copies of SharpCap, SGP and NINA stumble in the connection process when they request the read modes from the U16M. The ASCOM drivers I have which I think are the last ones that were available from Andor do not seem to be able to report the read mode(s) in a way those packages are expecting so process of linking to the camera stops there. There may be other fails waiting to be discovered further down in the connection process but in my case, they get stuck there. I have an old version of Nebulosity that runs on a Windows 7 Ultimate laptop that will mount the camera successfully but that is hardly a solution since I lose a lot of other functionality on that machine with respect to automation (focusing, plate solving, etc.).

    So my hope was that since DL once supported Apogee cameras and filter wheels, someone there would have maintained the latest working ASCOM drivers for the U16M. I would want to know if they are different or more up-to-date than mine. In addition, I'd be willing to buy MaximDL to run this camera if I was confident that software would manage the camera connection successfully. I have an old version of it on an optical disk with the coil-bound printed manual somewhere but haven't located it yet.

    I will re-test the W10 connection process more carefully to make sure I've got a working combination of drivers, software settings, and operating system configuration. I'll touch base again if I can't make further progress. I have also emailed Cambridge for help on this.
     
  4. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    3,453
    Dave, mailing Cambridge won't help (hee hee). It's Oxford Instruments that owns Andor. You've confused 2 universities.
    I recall we had to get the Andor Apogee control program as well to test the camera was being seen correctly. Sometimes it was coming up as the wrong device (a filter wheel or something) due to an error in their code and driver versions.
    From my notes I see:
    AndorDriverPack2Setup-2.104.30000.0
    apgSwInstall-x86
    ApogeeAscomDriver.5.5.4
    I seem to recall the ASCOM driver did not work right.

    You can get a 30 day demo of MaxIm and try it out. Go to the MaxIm DL Pro page, and click on the Blue DEMO tab.
    https://diffractionlimited.com/product/maxim-dl/

    Other threads on the Apogee topic:
    https://forum.diffractionlimited.com/posts/36705/
    https://forum.diffractionlimited.com/posts/32383/
    https://forum.diffractionlimited.com/posts/32462/
    https://forum.diffractionlimited.com/posts/34385/
     

Share This Page