Resolved ST-2000XM external guider not working properly

Discussion in 'Legacy Models (ST, STL, etc.)' started by JoeGafford, Jul 5, 2019.

  1. JoeGafford

    JoeGafford Standard User

    Joined:
    Feb 22, 2016
    Messages:
    7
    Location:
    Denver, CO
    This could be a Windows 10 issue. My external guider is not working properly on my ST-2000XM camera. An image will come up, but the shutter click for doing auto dark not present. I get a flipped image from the internal guider plus a dark bar on the bottom of the image in CCD Soft and the Sky X. Internal guider image only with external camera selected in CCDops. Toggling the config setting for the ST camera from pro to classic and back again in the driver worked a month ago, but not now. Removing and reinstalling the latest driver didn't work either.

    I tried this in my old Win 7 machine downstairs with the older driver and the external guider works properly with the proper shutter clicking.

    Windows 10 latest update on field laptop and main desktop, no choice folks! CCD Soft and Sky X, latest updates. CCDops: Get internal image only with external guider selected.

    Joe
     
  2. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    6,163
    @Bill will have to help you with this. He'll be back in the office on Monday.
     
  3. Bill

    Bill SBIG Service and Repairs Staff Member

    Joined:
    Oct 12, 2014
    Messages:
    418
    Joe,

    Since the camera has the External Guide Port, you would use the Pro drivers. It doesn't make sense that, with the External Guider selected you'd be getting an image from the internal ccd. Perhaps you can remove all SBIG software from the field laptop and download the DriverChecker64 and CCDOps anew?

    -Bill
     
  4. JoeGafford

    JoeGafford Standard User

    Joined:
    Feb 22, 2016
    Messages:
    7
    Location:
    Denver, CO
    I did uninstall all of that at first. I just did again as you recommended, but still no proper response. Driver checker dated 2-19-2019. Problem came with the Windows 10 updates from last December. At that time, I toggled the Config from ST-RGH connecter Pro selection to off, close, open to on again and got it to work. Now the external guider does not work at all except on my old win 7 desktop computer. Not on my main desktop with Win 10 and field computer with the Win 10 installed a couple of months ago as a couple my other unrelated programs in it quit Win 7 support.
     
  5. Bill

    Bill SBIG Service and Repairs Staff Member

    Joined:
    Oct 12, 2014
    Messages:
    418
    Joe,

    I apologize but I'm not sure how to deal with that. It's apparent that the equipment works and that it's a "Windows thing". Perhaps someone else can offer a solution.

    -Bill
     
  6. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    6,163
  7. Adam Robichaud

    Adam Robichaud Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    704
    Location:
    Ottawa
    Can you give the version numbers of SBIGUDrv.dll on both the Windows 7 and 10 PCs? We did do some work on External Shutter control in the early days of the acquisition, but this would have been years ago at this point.
     
  8. JoeGafford

    JoeGafford Standard User

    Joined:
    Feb 22, 2016
    Messages:
    7
    Location:
    Denver, CO
    Both Win 10 machines: 4.99 Build 7, File version: 4.9.9.7
    Old Win 7 machine: 4.97 build 1, File version: 4.9.7.1

    I tried removing current driver to an older version in field laptop, still the external guider not working.
     
  9. Adam Robichaud

    Adam Robichaud Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    704
    Location:
    Ottawa
    The External Shutter changes predate both of those versions, so it's likely something else is the culprit. Would you be willing to let me poke around on the Windows 10 PC via TeamViewer to get a baseline of information going, and do some troubleshooting?
     
  10. JoeGafford

    JoeGafford Standard User

    Joined:
    Feb 22, 2016
    Messages:
    7
    Location:
    Denver, CO
    We can do the Team Viewer, but my internet service drops out. It has been a problem in my neighborhood for quite awhile.
     
  11. JoeGafford

    JoeGafford Standard User

    Joined:
    Feb 22, 2016
    Messages:
    7
    Location:
    Denver, CO
    I got the external guider to work now, it was a Windows 10 issue. Win 10 cronies did something but when I updated the laptop to the Windows 10 Feature update, both guiders worked again. I did this last night and just tried it again. Both guiders are now working in CCDops, CCD Soft and SkyX. The Feature update in Win 10 took 25 minutes to upload, 45 minutes to update on a SSD.

    Joe
     
  12. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    6,163
    That is odd. Please let us know if you experience any problems going forward.
     
  13. JoeGafford

    JoeGafford Standard User

    Joined:
    Feb 22, 2016
    Messages:
    7
    Location:
    Denver, CO
    I went out to the DSS last night. No problems with the external guider. The laptop had Windows 10 installed due to 2 programs no longer support Win 7. That took only 15 minutes to upgrade due to possible fudging by Microsoft with the latter Win 7 updates. This "Feature" upgrade took quite awhile though. This doesn't explain why it didn't work with the main desktop that always had Win 10 on it. I'll check this with the desktop later.

    Joe
     

Share This Page