I damaged my ST-4000

Discussion in 'STF Series CCD Cameras' started by Morris "Mojo" Jones, Nov 23, 2014.

  1. Morris "Mojo" Jones

    Morris "Mojo" Jones Standard User

    Joined:
    Nov 8, 2014
    Messages:
    2
    Camera: ST-4000XCM 40710007

    This weekend out testing a new laptop and all new capture software, TheSkyX sent the dec axis around into a knot, about 720 degrees.

    After straightening everything back out, I noticed I was getting nothing but dark images. The shutter wasn't opening.

    In an effort to get it unstuck, I believe I manhandled it badly. It started operating, but you could hear it, where it's usually silent. Now I believe it has scratched up the cover glass on the sensor, and probably has worse mechanical problems.

    And of course you can see the effect in the images, as attached.

    Could you help me out with a repair authorization? (Or should I just send it in?)

    Mojo
    --
    Morris Jones
    Monrovia, CA
     

    Attached Files:

  2. Bill

    Bill SBIG Service and Repairs Staff Member

    Joined:
    Oct 12, 2014
    Messages:
    494
    Morris,

    It's awful hard to scratch the cover glass on the ccd. You took off the top cover of the camera and went inside?
     
  3. Morris "Mojo" Jones

    Morris "Mojo" Jones Standard User

    Joined:
    Nov 8, 2014
    Messages:
    2
    Well that's encouraging. :) So what I suspect then is some lubricant or other material fouling the cover glass.

    I did not remove the cover. I'm not uncomfortable with doing that, but I never have. Do you suggest I open it up and have a look?

    Mojo
     
  4. Bill

    Bill SBIG Service and Repairs Staff Member

    Joined:
    Oct 12, 2014
    Messages:
    494
    No, but that's the only way you would've scratched the ccd though.
     

Share This Page