Resolved ST and STL Series Camera - New Driver Released

Discussion in 'STF Series CCD Cameras' started by Adam Robichaud, Nov 30, 2016.

  1. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    7,183
    The problem isn't one of neglect - Adam has put quite a bit of work into investigating this. It's just that the cause is a bit mysterious. I'm sure he'll get to the bottom of it shortly.
     
  2. Pedro Re

    Pedro Re Standard User

    Joined:
    Dec 30, 2016
    Messages:
    4
    I'm also glad I found this thread. I was having problems connecting my two STL11000 and now I know why. Please keep us posted
     
    Last edited: Jan 3, 2017
  3. Adam Robichaud

    Adam Robichaud Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    788
    Location:
    Ottawa
    Hi All,

    I hope you had a good Holiday. I've just plugged in our ST-2K for final testing of the new driver. I have a few more cameras to go before releasing, but barring any quality-control failures I suspect it should be out today or tomorrow.

    Cheers,
    -Adam
     
  4. FloEd

    FloEd Standard User

    Joined:
    Jan 5, 2017
    Messages:
    6
    I have the same trouble with my ST-2k : after driver update from "sbigdriverchecker64", my ST-2k cannot be used with Prism10 automation software... I'm very disappointed. I hope a quick update from sbig to solve this issue.
    I'm running Win10 64bits.
    Regards

    Florian
     
    Last edited: Jan 6, 2017
  5. Andrew Lindsay

    Andrew Lindsay Standard User

    Joined:
    Dec 30, 2016
    Messages:
    5
    Hi,

    I have been going mad. I upgraded all my drivers and the camera won't connect. I've now tried to wind back to the older drivers as suggested here, but no luck yet. I'll continue my search. I am running Win7-64.

    Hope there is an elegant solution soon.

    Regards

    Andrew
     
  6. JMB

    JMB Standard User

    Joined:
    Dec 9, 2016
    Messages:
    10
    Hello Adam,

    Tuesday this week you said
    ...and we are Saturday. Any idea when this will be ready?

    Thanks,
    JMarc
     
  7. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    7,183
    It has been released
     
  8. JMB

    JMB Standard User

    Joined:
    Dec 9, 2016
    Messages:
    10
    OK good to know thank you.
     
  9. FloEd

    FloEd Standard User

    Joined:
    Jan 5, 2017
    Messages:
    6
    Perfect, many thanks for this update. Working fine with Prism10 and CCDSoft now.
     
  10. Pedro Re

    Pedro Re Standard User

    Joined:
    Dec 30, 2016
    Messages:
    4
    Thanks
     
  11. Pedro Re

    Pedro Re Standard User

    Joined:
    Dec 30, 2016
    Messages:
    4
    Does it work in W7 as well?
     
  12. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    3,747
  13. HomerPepsi

    HomerPepsi Standard User

    Joined:
    May 10, 2015
    Messages:
    1
    New driver allows the ST-8300M to connect again. Thanks.
     
  14. Adam Robichaud

    Adam Robichaud Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    788
    Location:
    Ottawa
    Apologies for not making an announcement re: the new driver Friday, time got away from me before I had a chance to post the update. If anyone has an issues with the new driver and their ST/STL cameras, please don't hesitate to let us know.
     
  15. Larry Phillips

    Larry Phillips Cyanogen Customer

    Joined:
    Oct 16, 2014
    Messages:
    29
    Where can I find the new version? I can't find a link on the website.

    Larry
     
  16. Adam Robichaud

    Adam Robichaud Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    788
    Location:
    Ottawa
    You can download the new driver via SBIG Driver Checker, or from your camera's store page, via the download tab.
     
    Last edited: Jan 10, 2017
  17. Pedro Re

    Pedro Re Standard User

    Joined:
    Dec 30, 2016
    Messages:
    4
    The correct link is

    ftp://ftp.sbig.com/pub/SetupDriverChecker64.exe
     
  18. Adam Robichaud

    Adam Robichaud Staff Member

    Joined:
    Sep 29, 2014
    Messages:
    788
    Location:
    Ottawa
    Thanks @Pedro Re — apparently Xenforo doesn't like links to the ftp:// protocol...
     
  19. Iver

    Iver Standard User

    Joined:
    Feb 14, 2015
    Messages:
    4
    I have an ST-8300M and haven't updated the divers for a couple of years. Is it advisable or recommended to update older cameras regularly? Does if it ain't broke don't fix it apply here?
     
  20. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    7,183
    There is always a small risk of "bricking" when you reflash a device, which would require sending it into service for reprogramming. So I would recommend flashing if you need to, and not flashing if you don't.
     

Share This Page