ST-I Won’t Connect

Discussion in 'STF Series' started by David Woolf, Aug 8, 2018.

  1. David Woolf

    David Woolf Standard User

    Joined:
    Aug 8, 2018
    Messages:
    1
    ST-I worked fine at home, now I’m at the Nebraska Star Party and I Keep getting “cannot connect to camera error 27.” The light is on, and I hear the shutter trigger. Happens in PHD2 and CCDops. Tried rebooting, Just updated drivers and using new cables. REALLY need my guide camera! Spent the $ on SBIG just so stuff like this wouldn’t happen.
     
  2. JoshuaHufford

    JoshuaHufford Cyanogen Customer

    Joined:
    Oct 10, 2014
    Messages:
    330
    Have you tried a different USB cable? The STi uses the max current supplied by a USB port, if the wires in your cable aren't large enough it won't work properly, even if the cable is new. Best to use the cable that came with the camera as it has heavier wires.

    How long is the cable you are using?

    Are you running through a hub?

    Might check the power management settings on your laptop, make sure no USB power saving options are turned on. If you have a powered hub you might try that between the camera, some laptop USB ports don't provide a lot of power.
     
  3. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    6,875
    Those are good suggestions. The camera takes maximum permitted power from USB, so if you have the wrong cable it will not work reliably. If you are using a hub, make sure it is a powered hub. If you are using a long cable, make sure it's the one that came with the camera - it has thicker power wiring than standard cables.

    If you can find a neighbour's computer that has SBIG drivers, maybe try connecting to that, just to rule out problems on the PC side.
     

Share This Page