Unable to Establish COM-Link With Ethernet

Discussion in 'STX and STXL' started by Mike Hambrick, Apr 18, 2019.

  1. Mike Hambrick

    Mike Hambrick Cyanogen Customer

    Joined:
    Jul 13, 2016
    Messages:
    167
    I have been trying to get my STXL16200 to connect to CCDOps using an Ethernet cable instead of the USB, but I keep getting an error saying that the camera can not be found. I think I have checked all the right boxes; In the Graphics / Com setup the interface is set to Ethernet and I entered the camera IP address in the box. In the preferences menu I have the Allow Ethernet Support box checked.

    Am I missing something else ? I am running Windows 1o Home Version 1809 (last updated on 2/27/2019)

    I can connect to the camera via USB without any problems
     
  2. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    6,887
    You should be able to log into the camera with a web browser. Try that first. Also please review the manual for instructions.
     
  3. Bill

    Bill SBIG Service and Repairs Staff Member

    Joined:
    Oct 12, 2014
    Messages:
    468
    In the Graphics / Com setup the interface is set to Ethernet and I entered the camera IP address in the box.

    Mike,

    Did you click the "Detect" button?

    -Bill
     
  4. Mike Hambrick

    Mike Hambrick Cyanogen Customer

    Joined:
    Jul 13, 2016
    Messages:
    167
    Bill & Doug.

    Here is what I am getting:
    From the Graphics / Com menu: The IP address is the one given in the STXL16200 manual.
    upload_2019-4-19_21-23-59.png

    When I click Detect I get the following error message:
    upload_2019-4-19_21-25-35.png

    To Doug's suggestion when I type the IP address above into my browser I get the following results:
    upload_2019-4-19_21-31-6.png
     
  5. Mike Hambrick

    Mike Hambrick Cyanogen Customer

    Joined:
    Jul 13, 2016
    Messages:
    167
    Also, just to see if it made any difference I tried turning off my Webroot virus protection. I still got the same error when trying to connect.
     
  6. Doug

    Doug Staff Member

    Joined:
    Sep 25, 2014
    Messages:
    6,887
  7. Bill

    Bill SBIG Service and Repairs Staff Member

    Joined:
    Oct 12, 2014
    Messages:
    468
    then click on Detect.
     
  8. Mike Hambrick

    Mike Hambrick Cyanogen Customer

    Joined:
    Jul 13, 2016
    Messages:
    167
    So I went to my browser and clicked on the IP address when it asked if I wanted to go to that address and got this message:
    upload_2019-4-24_21-32-27.png
     
  9. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    3,484
    Mike,
    I've been following this thread, and I think you have a more fundamental problem.
    To talk to the camera's default IP address, your PC has to be on the same network. e.g. it has to be on the 192.168.0.XXX network.

    What's the IP address of your computer's ethernet port?
    from a command prompt:
    ipconfig /all

    I think what you may need to do is:
    Put the computer and the camera on the simplest network.
    e.g. camera -> crossover cable -> PC ethernet adapter
    e.g. camera -> cable -> network switch -> cable -> PC ethernet adapter

    Write down your existing netowrk settings for the computer's network adapter (either from ipconfig or from network adapter settings, IPv4 properties)
    In the network adapter settings, IPV4, set a Static IP address in
    e.g. IP 192.168.0.123
    Netmask 255.255.255.0
    Default Gateway 192.168.0.100

    Then you will be able to access the camera and change its settings, including it's IP address.

    If you are then putting the camera on a network with a different address e.g. 192.168.1.XXX then change its settings.
     
  10. Mike Hambrick

    Mike Hambrick Cyanogen Customer

    Joined:
    Jul 13, 2016
    Messages:
    167
    Thanks Colin. I expect that you are correct, and that my problem is due to something like you are describing. I am not exactly sure what you mean by the command prompt but I can ask my IT guys at work. I will check this out when I get home tonight

    As for changing tha IP address of the ethernet port, is this something that I will have to switch back and forth depending on what I am doing ? I normally don't use the ethernet port on my laptop because we have a wireless router.
     
  11. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    3,484
    Hi Mike,
    Yep, we're on the right track here.
    When this is 100% finished, the camera will be on a new IP address that happily lives on your observatory's local area network.
    Then you won't have to switch anything ever again.
    This is just a "setup" exercise done one time with a new camera.

    For home networks, the two most common IP address ranges are 192.168.0.XXX and 192.168.1.XXX, where XXX is 0 to 255, and normally you start at 1 for your router.

    Since our factory has no idea what your network address will be, we take a guess, and set the camera up for 192.168.0.100.
    In your case, this is likely the wrong guess.

    So, how to fix?
    One time only - connect a PC to the camera, on the 192.168.0.XXX network, and then reprogram the camera's address to be 192.168.1.100 (for example).

    Command prompt is also known as the DOS prompt.
    Press Start button. In the search box, "cmd". You'll see something like this:
    ipconfig.png
    In the black command prompt window (used to be called the DOS prompt), I typed in:
    ipconfig

    and you can see it shows my network adapter settings.

    If you tell me what yours says, then we'll know what is going on - and then the next step will be whether we have to change your network settings to talk to the camera for that first time initial setup.

    Ask your guys at work - or maybe take the camera in and one of the IT folks will help out.
     
  12. Mike Hambrick

    Mike Hambrick Cyanogen Customer

    Joined:
    Jul 13, 2016
    Messages:
    167
    Thanks Colin
    My IPv4 address is 192.168.1.14. Below is a screen shot. If you can tell me how to proceed from here that will be a big help. FYI I am leaving the country first thing in the morning on a business trip for three weeks, so I will not be able to follow up until I get back.
    upload_2019-4-27_23-3-4.png
     
  13. Colin Haig

    Colin Haig Staff Member

    Joined:
    Oct 27, 2014
    Messages:
    3,484
    OK, well ping me when you get back.
    What we're going to do is set up the wired ethernet connection on your laptop to 192.168.0.123, and connect the camera to the wired ethernet side.
    We'll leave the wireless side alone, and your network is 192.168.1.XXX so we need to eventually get the camera onto that network.

    Start by going into network settings:
    hambrick1.png
    Select the wired Ethernet adapter - my example has many, but it usually just says Ethernet:
    hambrick2.png
    Select the IP v4 properties:
    hambrick3.png
    Write down the existing settings (or take a screen shot) so you can put it back later.
    Set up the IP address and network info to the following:
    hambrick4.png

    Now that is done, hit ok, close all those windows.
    Plug the network cable in between the laptop Ethernet jack and the camera, and then you should be able to talk to it by following the original instructions.
    eg browser to http://192.168.0.100
    You might have to temporarily disable the WiFi on the laptop.
    Then you'll want to follow the steps to change the IP address and network of the camera to put it onto an available network IP address on 192.168.1.xxx.
    Some routers automatically assign a bunch of IP addresses. You'll need to pick one that is not in the assigned range.

    Worst case, I can probably TeamViewer in to your machine when you get back.
    Cheers
    Colin
     
  14. Mike Hambrick

    Mike Hambrick Cyanogen Customer

    Joined:
    Jul 13, 2016
    Messages:
    167
    Hi Colin. I am back in the country finally. I will try following up on your instructions over the next few days and let you know how it turns out.
    Mike
     

Share This Page